How to remove a cluster setting?

I made the following setting to my Elasticsearch cluster in order to
decommission some old nodes in the cluster. After removed these old nodes,
now I need to re-enable the cluster to allocate shards on those '10.0.6.*'
nodes. Does anyone know how to remove this setting?

    PUT /_cluster/settings 
    { 
       "transient": { 
          "cluster.routing.allocation.exclude._ip": "10.0.6.*" 
       } 
    } 

Thanks in advance for any help!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/53df40a8-a248-4373-b789-e0490e3dab8a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

1 Like

Try:

PUT /_cluster/settings
{
"transient": {
"cluster.routing.allocation.exclude._ip": ""
}
}

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 22 juil. 2014 à 02:50, Jeffrey Zhou jeffreyzhou2014@gmail.com a écrit :

I made the following setting to my Elasticsearch cluster in order to decommission some old nodes in the cluster. After removed these old nodes, now I need to re-enable the cluster to allocate shards on those '10.0.6.*' nodes. Does anyone know how to remove this setting?

    PUT /_cluster/settings 
    { 
       "transient": { 
          "cluster.routing.allocation.exclude._ip": "10.0.6.*" 
       } 
    } 

Thanks in advance for any help!

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/53df40a8-a248-4373-b789-e0490e3dab8a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/054923B7-1941-4FA0-B4B7-51A99A85F0B3%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.

why this didn't work on my es :

GET /_cluster/settings
{
"persistent": {
"discovery": {
"zen": {
"minimum_master_nodes": "2"
}
}
},
"transient": {
"indices": {
"recovery": {
"translog_size": "1024kb",
"concurrent_streams": "3",
"translog_ops": "2000",
"max_bytes_per_sec": "400mb",
"file_chunk_size": "1024kb"
}
}
}
}

PUT _cluster/settings
{
"transient": {
"indices.recovery.translog_size":""
}
}

response:
{
"acknowledged": true,
"persistent": {},
"transient": {}
}

When I do GET again, this setting still exists.

On Tuesday, July 22, 2014 at 8:50:10 AM UTC+8, Jeffrey Zhou wrote:

I made the following setting to my Elasticsearch cluster in order to
decommission some old nodes in the cluster. After removed these old nodes,
now I need to re-enable the cluster to allocate shards on those '10.0.6.*'
nodes. Does anyone know how to remove this setting?

    PUT /_cluster/settings 
    { 
       "transient": { 
          "cluster.routing.allocation.exclude._ip": "10.0.6.*" 
       } 
    } 

Thanks in advance for any help!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/24d2a534-fe0f-4956-9d59-38b0300393d3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

This is a known issue​, see
https://github.com/elasticsearch/elasticsearch/issues/6732​

On 15 January 2015 at 22:01, Gary Gao garygaowork@gmail.com wrote:

why this didn't work on my es :

GET /_cluster/settings
{
"persistent": {
"discovery": {
"zen": {
"minimum_master_nodes": "2"
}
}
},
"transient": {
"indices": {
"recovery": {
"translog_size": "1024kb",
"concurrent_streams": "3",
"translog_ops": "2000",
"max_bytes_per_sec": "400mb",
"file_chunk_size": "1024kb"
}
}
}
}

PUT _cluster/settings
{
"transient": {
"indices.recovery.translog_size":""
}
}

response:
{
"acknowledged": true,
"persistent": {},
"transient": {}
}

When I do GET again, this setting still exists.

On Tuesday, July 22, 2014 at 8:50:10 AM UTC+8, Jeffrey Zhou wrote:

I made the following setting to my Elasticsearch cluster in order to
decommission some old nodes in the cluster. After removed these old nodes,
now I need to re-enable the cluster to allocate shards on those '10.0.6.*'
nodes. Does anyone know how to remove this setting?

    PUT /_cluster/settings
    {
       "transient": {
          "cluster.routing.allocation.exclude._ip": "10.0.6.*"
       }
    }

Thanks in advance for any help!

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/24d2a534-fe0f-4956-9d59-38b0300393d3%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/24d2a534-fe0f-4956-9d59-38b0300393d3%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X_gRwFZ1gyoXHrKU5-wWqyCg6d9p2in2jx%2B6jpyCyeRGw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.