How do you enable modules via the command line

I'm trying to run metric beats without having a configuration file. I was wondering how do you enable modules?

I tried

-E modules.docker.enable=true
-E module.docker.enable=true
-E metricbeat.modules=[module.docker.enable=true]

But does not appear to work.

Hello,

Here is an example of enabling the apache & mysql modules:

metricbeat modules enable apache mysql

More documentation and examples can be found here:
https://www.elastic.co/guide/en/beats/metricbeat/current/configuration-metricbeat.html

except in your example it does not enable it via the command line runner. So it won't work in Docker unless we create a custom image.

Here is the solution I have used in my project that sets up an ELK stack with zero custom images or external configuration files.

The whole project is in https://github.com/trajano/elk-swarm/