How many memory is require (win7 64bit)?

Hi !

i want to use elasticsearch for a company wiki an my machine is win7 64bit
with 8GB Ram.

know i want to start like service. i stopped the current elasticsearch.bat
and call service.bat by kontextmenue start as admin

i get the message that the command is unable to start because there is not
enough memory.

my machine to small or is there a possiblity to define a special parameter?

reagards Jan

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b2a8893f-d730-41cc-b833-f1ef82a93f98%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

If i start elasticsearch-service-x64.exe the window will show and hide in
the next moment !

reagards Jan

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/70962568-1571-4ca2-9307-e9f0126ec509%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Did you set any memory settings for the JVM HEAP?
If so, you might have forgotten to add m or g after the size. Like ES_HEAP_SIZE=1024 instead of 1024m

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr https://twitter.com/elasticsearchfr | @scrutmydocs https://twitter.com/scrutmydocs

Le 25 févr. 2015 à 14:45, jan99 jan@tappenbeck.net a écrit :

If i start elasticsearch-service-x64.exe the window will show and hide in the next moment !

reagards Jan

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/70962568-1571-4ca2-9307-e9f0126ec509%40googlegroups.com https://groups.google.com/d/msgid/elasticsearch/70962568-1571-4ca2-9307-e9f0126ec509%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8A80859B-0A0B-4549-B7EC-AA17734661B3%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.

HI !

i did not set anything like this !

Did you set any memory settings for the JVM HEAP?

where did i add this parameter - did you have a link?

If so, you might have forgotten to add m or g after the size. Like
ES_HEAP_SIZE=1024 instead of 1024m

no i did !

regards Jan

Am Mittwoch, 25. Februar 2015 14:43:50 UTC+1 schrieb jan99:

Hi !

i want to use elasticsearch for a company wiki an my machine is win7 64bit
with 8GB Ram.

know i want to start like service. i stopped the current elasticsearch.bat
and call service.bat by kontextmenue start as admin

i get the message that the command is unable to start because there is not
enough memory.

my machine to small or is there a possiblity to define a special parameter?

reagards Jan

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/4e696b9f-8fff-4f5e-ac1d-e9311232616f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi !

current i found the side:
http://www.elasticsearch.org/guide/en/elasticsearch/guide/current/heap-sizing.html

so i define a windows environment variable called ES_HEAP_SIZE = 1024

now i started the service.bat - but there is no success!

no service will installed !

when i try to elasticsearch-service-x64 via start as ... in the contextmenü
the window will open and close !

and now?

regards jan

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5630bce5-2324-49a9-abbf-e495f83e97f5%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

I guess that you did this? http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/_installation.html http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/_installation.html
Is that right?

Then you tried this?

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup-service-win.html http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup-service-win.html

If not, please do.
If yes, please describe which exact step does not work as expected.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr https://twitter.com/elasticsearchfr | @scrutmydocs https://twitter.com/scrutmydocs

Le 25 févr. 2015 à 16:04, jan99 jan@tappenbeck.net a écrit :

Hi !

current i found the side: http://www.elasticsearch.org/guide/en/elasticsearch/guide/current/heap-sizing.html http://www.elasticsearch.org/guide/en/elasticsearch/guide/current/heap-sizing.html

so i define a windows environment variable called ES_HEAP_SIZE = 1024

now i started the service.bat - but there is no success!

no service will installed !

when i try to elasticsearch-service-x64 via start as ... in the contextmenü the window will open and close !

and now?

regards jan

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5630bce5-2324-49a9-abbf-e495f83e97f5%40googlegroups.com https://groups.google.com/d/msgid/elasticsearch/5630bce5-2324-49a9-abbf-e495f83e97f5%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1B93D9F6-F336-4585-848C-0CA59593D62C%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.

Hi !

now the service runs ! my problem is to start service correct !!!

yesterday i only call "service.bat"

today: service.bat install !!

service will install and i am able to start the service via dialog.

now i go to the next steps ....

regards jan :slight_smile:

Am Mittwoch, 25. Februar 2015 14:43:50 UTC+1 schrieb jan99:

Hi !

i want to use elasticsearch for a company wiki an my machine is win7 64bit
with 8GB Ram.

know i want to start like service. i stopped the current elasticsearch.bat
and call service.bat by kontextmenue start as admin

i get the message that the command is unable to start because there is not
enough memory.

my machine to small or is there a possiblity to define a special parameter?

reagards Jan

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b50e19f5-a047-40ef-9688-3f6f16e014bc%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.