How to access remotely to elasticsearch 5?


(sen) #1

Hello folks,

I want to access remotely to my elasticsearch version 5.
I tried to add this line in the elasticseach.yml file as I did with elassticsearch version 4 (which worked):

network.bind_host: 0.0.0.0

however, it doesn't work and elasticsearch displays an error and does not work.

[sagemcom@localhost bin]$ ./elasticsearch
[2016-11-07T12:17:58,432][INFO ][o.e.n.Node               ] [] initializing ...
[2016-11-07T12:17:58,564][INFO ][o.e.e.NodeEnvironment    ] [NqVMQ-B] using [1] data paths,        mounts     [[/home (/dev/mapper/centos-home)]], net usable_space [13.5gb], net total_space [23gb], spins? [possibly], types [xfs]
[2016-11-07T12:17:58,565][INFO ][o.e.e.NodeEnvironment    ] [NqVMQ-B] heap size [1.9gb], compressed ordinary object pointers [true]
[2016-11-07T12:17:58,574][INFO ][o.e.n.Node               ] [NqVMQ-B] node name [NqVMQ-B] derived from node ID; set [node.name] to override
[2016-11-07T12:17:58,577][INFO ][o.e.n.Node               ] [NqVMQ-B] version[5.0.0], pid[3400], build[253032b/2016-10-26T04:37:51.531Z], OS[Linux/3.10.0-123.el7.x86_64/amd64], JVM[Oracle   Corporation/Java HotSpot(TM) 64-Bit Server VM/1.8.0_73/25.73-b02]
[2016-11-07T12:17:59,776][INFO ][o.e.p.PluginsService     ] [NqVMQ-B] loaded module [aggs-matrix-stats]
[2016-11-07T12:17:59,776][INFO ][o.e.p.PluginsService     ] [NqVMQ-B] loaded module [ingest-common]
[2016-11-07T12:17:59,776][INFO ][o.e.p.PluginsService     ] [NqVMQ-B] loaded module [lang-expression]
[2016-11-07T12:17:59,777][INFO ][o.e.p.PluginsService     ] [NqVMQ-B] loaded module [lang-groovy]
[2016-11-07T12:17:59,777][INFO ][o.e.p.PluginsService     ] [NqVMQ-B] loaded module [lang-mustache]
[2016-11-07T12:17:59,777][INFO ][o.e.p.PluginsService     ] [NqVMQ-B] loaded module [lang-painless]
[2016-11-07T12:17:59,778][INFO ][o.e.p.PluginsService     ] [NqVMQ-B] loaded module [percolator]
[2016-11-07T12:17:59,779][INFO ][o.e.p.PluginsService     ] [NqVMQ-B] loaded module [reindex]
[2016-11-07T12:17:59,779][INFO ][o.e.p.PluginsService     ] [NqVMQ-B] loaded module [transport-netty3]
[2016-11-07T12:17:59,780][INFO ][o.e.p.PluginsService     ] [NqVMQ-B] loaded module [transport-netty4]
[2016-11-07T12:17:59,781][INFO ][o.e.p.PluginsService     ] [NqVMQ-B] no plugins loaded
[2016-11-07T12:18:03,138][INFO ][o.e.n.Node               ] [NqVMQ-B] initialized
[2016-11-07T12:18:03,139][INFO ][o.e.n.Node               ] [NqVMQ-B] starting ...
[2016-11-07T12:18:03,349][INFO ][o.e.t.TransportService   ] [NqVMQ-B] publish_address {127.0.0.1:9300}, bound_addresses {[::]:9300}
[2016-11-07T12:18:03,355][INFO ][o.e.b.BootstrapCheck     ] [NqVMQ-B] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks
ERROR: bootstrap checks failed
max file descriptors [4096] for elasticsearch process likely too low, increase to at least [65536]
max virtual memory areas vm.max_map_count [65530] likely too low, increase to at least [262144]
[2016-11-07T12:18:03,364][INFO ][o.e.n.Node               ] [NqVMQ-B] stopping ...
[2016-11-07T12:18:03,402][INFO ][o.e.n.Node               ] [NqVMQ-B] stopped
[2016-11-07T12:18:03,402][INFO ][o.e.n.Node               ] [NqVMQ-B] closing ...
[2016-11-07T12:18:03,417][INFO ][o.e.n.Node               ] [NqVMQ-B] closed

Thanks in advance.

S


(Magnus Bäck) #2

The log you posted lists two errors that makes Elasticsearch refuse to start. Start by addressing them. They have nothing to do with your setting of network.bind_host.


(sen) #3

ok, thanks.
And what do I have to do to access remotely my elasticsearch server version 5 ?


(Magnus Bäck) #4

I don't expect you to have to do much else. However, I suspect network.host is a better choice than network.bind_host.


(sen) #5

it is not nice of you to expect that about me but I already tried that and it did not work either.


(Magnus Bäck) #6

it is not nice of you to expect that about me

I think you misunderstood what I wrote.

but I already tried that and it did not work either.

Have you fixed the two bootstrap check errors?


(sen) #7

I put in the configuration file: http.host: myIpAddress and it worked !


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.