How to confirm CORS is enabled - Elasticsearch 5.x


(somerandomguy) #1

Hi.
Have installed ES 5.0 with everything else.
I have put the following in the /etc/elasticsearch/elasticsearch.yml:

http.cors.enabled : true
http.cors.allow-origin : "*"
http.cors.allow-methods : OPTIONS, HEAD, GET, POST, PUT, DELETE
http.cors.allow-headers : X-Requested-With,X-Auth-Token,Content-Type, Content-Length

But when I point my current Elasticsearch-Head to this newly installed ES I am unable to connect. Anything else that needs to get set?

TIA.


(Mark Walkom) #2

I don't think head is compatible with 5.0, is it?

You can see CORS settings here - https://www.elastic.co/guide/en/elasticsearch/reference/5.0/modules-http.html#_settings_2 - but otherwise you may want to ask the author of head :slight_smile:


(somerandomguy) #3

Hi, thanks.
I believe that you can run HEAD as a standalone and point it to your ES Cluster and this is what I have done but I get nothing. Is there anyway to tell that my CORS is enabled and working?


#4

@somerandomguy, I have the same problem, do you have solution?

Thanks


(somerandomguy) #5

Hi Yep.
I had an old version of Head on my other cluster.
I removed it and then re-installed and now I can hit this url and all good :slight_smile:

http://old_cluster_that_I_installed_head:9200/_plugin/head/index.html?base_uri=http://my_new_server_that_doesnt'_have_head_installed:9200

:slight_smile:


(system) #6