How to disable http in elasticsearch

How to disable http on data or master nodes , how to specify in cr file. Please anyone help me out.

You can add this into elasticsearch.yml of your node
node.remote_cluster_client: false

I am getting error for this one . @ylasri, above mentioned command is regarding to remote clusters. I am asking the command to disable http on master or data-ingest nodes . Can anyone please answer this one.

Will HTTP enabled by default on all nodes?

Why do you want to do this?

I want to setup ROR plugin only on client nodes. So, just want to disable http on master and ingest nodes. Can anyone answer how to config to disable http on master and ingest nodes.

This is not possible. The HTTP interface is required on all nodes.

1 Like

Thanks for replying @DavidTurner. But in the documentation, it has mentioned like, we can disable http . I am refering this document.

The docs you link are for a pretty old version in which the HTTP interface could be disabled. This feature was removed in https://github.com/elastic/elasticsearch/pull/29601.

2 Likes

@DavidTurner, Will it work for 6.8.8 and 6.8.7 versions? . I am not getting any error. But, the pod is not running. I tried disabled it in master pod. When I checked the logs
[2020-09-15T10:06:42,779][INFO ][o.e.l.LicenseService ] [elasticsearch-config-es-master-0] license [8be26267-2190-4d95-981c-e66d8e8bbf9c] mode [basic] - valid
[2020-09-15T10:06:45,375][INFO ][o.e.c.s.MasterService ] [elasticsearch-config-es-master-0] zen-disco-node-join[{elasticsearch-config-es-data-ingest-0}{4dp3XQ19RNCmeqfgdrY7-g}{wFtcOlasSn63juxDHtVmvg}{10.124.12.178}{10.124.12.178:9300}{ml.machine_memory=3221225472, ml.max_open_jobs=20, xpack.installed=true, ml.enabled=true}], reason: added {{elasticsearch-config-es-data-ingest-0}{4dp3XQ19RNCmeqfgdrY7-g}{wFtcOlasSn63juxDHtVmvg}{10.124.12.178}{10.124.12.178:9300}{ml.machine_memory=3221225472, ml.max_open_jobs=20, xpack.installed=true, ml.enabled=true},}
[2020-09-15T10:06:46,442][INFO ][o.e.c.s.ClusterApplierService] [elasticsearch-config-es-master-0] added {{elasticsearch-config-es-data-ingest-0}{4dp3XQ19RNCmeqfgdrY7-g}{wFtcOlasSn63juxDHtVmvg}{10.124.12.178}{10.124.12.178:9300}{ml.machine_memory=3221225472, ml.max_open_jobs=20, xpack.installed=true, ml.enabled=true},}, reason: apply cluster state (from master [master {elasticsearch-config-es-master-0}{Q1PqJnQ8TVugxpiahrv5Hg}{AZnyIP9yQfSfDHqAzHwL7Q}{10.124.15.21}{10.124.15.21:9300}{ml.machine_memory=3221225472, xpack.installed=true, ml.max_open_jobs=20, ml.enabled=true} committed version [15] source [zen-disco-node-join[{elasticsearch-config-es-data-ingest-0}{4dp3XQ19RNCmeqfgdrY7-g}{wFtcOlasSn63juxDHtVmvg}{10.124.12.178}{10.124.12.178:9300}{ml.machine_memory=3221225472, ml.max_open_jobs=20, xpack.installed=true, ml.enabled=true}]]])

Yes it works fine in 6.8.x versions.

If you are looking to implement access control, the Security functionality has been free since 6.8/7.1 - https://www.elastic.co/blog/security-for-elasticsearch-is-now-free

Yes, I tried with 6.8.8 for master one , but my pod is not running. I am not getting any error.
elastic-operator-0 1/1 Running 0 19h
elasticsearch-config-es-data-ingest-0 1/1 Running 0 19h
elasticsearch-config-es-master-0 0/1 Running 0 19h

When I described the pod , I am getting as shown below:

Warning Unhealthy 2m51s (x13844 over 19h) kubelet, gke-gtso-enter-gke-g-gtso-enter-gke-g-f4873fba-bexw (combined from similar events): Readiness probe failed: {"timestamp": "2020-09-16T05:20:46+0000", "message": "readiness probe failed", "curl_rc": "7"}
I already pasted logs in above comment. Any one has any idea, why it is like that

Ohh you didn't say you were running in containers. Http is required on all nodes there.

1 Like

Okay. Thank you