How to disable index migration on mapping change

(Eric) #1

While upgrading my plugin (from: 5.6, to: 6.5), I have updated some mappings. This seems to be causing kibana to think it needs to migrate data, and causing the below error.

server    log   [21:06:03.159] [error][status][plugin:spaces@6.5.4] Status changed from yellow to red - mapping set to strict, dynamic introduction of [default] within [search] is not allowed
server   error  [21:06:03.163] [fatal][root] Error: mapping set to strict, dynamic introduction of [default] within [search] is not allowed
    at Object.write (/Users/<user-path>/kibana/src/server/saved_objects/migrations/core/elastic_index.ts:106:23)
    at <anonymous>

 FATAL  Error: mapping set to strict, dynamic introduction of [default] within [search] is not allowed

 server crashed  with status code 1

Is there an easy way to disable this migration check.

(Tyler Smalley) #2

Have you migrated your 5.6 index to remove types by either using the Upgrade Assistant or manually?

Additionally, here is more information regarding how the automatic migrations work which were added in 6.5.

(Eric) #3

Updated manually.

(Tyler Smalley) #4

Was this done prior to upgrading to 6.x? What does GET .kibana/_mapping look like?

(Eric) #5

yes, it was done prior to the upgrade