How to disable syslog output?


I'm sorry if the answer is obvious. I thought it would be, but didn't find it, so I'm asking :confused:

I've noticed that a brand new Elasticsearch install (2.3 on Debian 8) is logging to syslog (as well as its regular own log file).

Is there a way to disable that ?



ES does not log to syslog... do you have any forwarding set up that would forward logs to syslog?

I don't think I have something setup, but the messages are definitely showing up in /var/log/daemon.log as well as in ES own logs.

Since ES is managed by SystemD, is there an "stdout" output for Elasticsearch that journald might intercept en forward to syslog ?

If journald is forwarding console output to syslog, you will want to change
your logging settings in config/logging.yml so the root logger isn't
writing to the console. If you startup ES out of the box without changing
settings, you will notice ES sends all the stuff it logs to
elasticsearch.log to standard out as well. You can change the behavior
there via the config/logging.yml

I've created an issue since logging to stdout is an anti-pattern for daemons.

Thanks for the help.