How to exclude APM self sent events capturing


(Arsalan Rabdanov) #1

Hi! I like a lot solution with elastic APM. I've configured tracing request through microservice gateway to microservices. Tracing timeline visualization looks great. But sometimes POST apm-server:8200/intake/v2/events breaks it.

How can i exclude it from timeline?


(Ron Cohen) #2

Hi Arsalan,

Thank you for your interest in Elastic APM!
Which agent are you using? Which version?

best,
Ron


(Arsalan Rabdanov) #3

"elastic-apm-node": "^2.0.1"


(Thomas Watson) #4

Hi Arsalan

Thanks for reporting this issue. The Node.js agent should automatically ignore requests to the APM Server so that they are not recorded. So it looks like you've encountered a bug.

Can I ask what you've configured the serverUrl config option to?

/thomas


(Arsalan Rabdanov) #5

APM running in docker container with name apm-server.
Node app running in container with link to apm-server and enviroment variable ELASTIC_APM_SERVER_URL=http://apm-server:8200.
serverUrl option is not set.


(Thomas Watson) #6

I've created a bug report for this on the agent repo: https://github.com/elastic/apm-agent-nodejs/issues/732

I'm currently investigating and will follow up once I know more.

Once again thanks for reporting this :slight_smile:

/thomas


(Arsalan Rabdanov) #7

i've sent a PR to repository. i found this bug


(system) closed #8

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.