How to force update the field format of kibana index pattern

Fields including 'pathname' are generated dynamically by apmserver.

"transaction.custom.pathname" is already a keyword field in the mapping, I keep creating new index patterns, "transaction.custom.pathname" is always in string format, I do n’t know why.

I tried the refresh field button, nothing changed.

Kibana picked up your changes correctly - in this list, both keyword and text types are under the "string" umbrella. This is indicated by the green dot in the "Aggregatable" column.

So why can't I use this field?

That should indeed work. Could you export the index pattern saved object and post it here along with the complete mapping?

The content of mapping is very much.

kibana index pattern

@wajika Sorry for the delay. I imported your index pattern, but for me the field shows up just fine when configuring a tag cloud visualization:

Which version of Kibana are you using?

ELK: 7.6.2

So what's the reason? The source index is also correct, but the field cannot be selected.
Is there any way I can operate?

In your first screenshot it's apm-*, in the last one apm*, is it possible you have both index patterns (one up to date, the other one not?). They might match the same data indices, but the saved meta data (like which fields are available) can be different.

Sorry, because I need to continue to work, so I keep looking for solutions. I tried to remove "apm-*" to solve the problem.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.