How to get index pattern mapping to properly display/use the keyword data type?

Kibana 5.3.0 (also occurred in 5.1.1. I just upgraded) on Windows 2012 R2

I loaded an index mapping into elasticsearch (5.3.0) using cURL that had several data types (ip,date,string,boolean, and keyword). When I go into the Kibana dev tools and perform a "GET /<my_indexname>/_mappings", the resulting mapping is exactly what I put in. When I go into Kibana to create a new index pattern, all of the "keyword" mappings for that index have turned into "string" data types and all the other mappings (date,ip,boolean) are properly set.

Because of this, the data mappings are not listed as Searchable, or Aggregatable, which was the point of making certain fields keywords.

Is there something obvious I may have done wrong (some setting, or something I need to add when declaring the mapping)?

What's your mapping look like?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.