How to free disk space for enterprise search?

Hi, I'm currently facing an issue and I don't really know how to fix it. Recently, my script for updating my engines is returning errors while I'm trying to delete/update documents on my engines. I saw into logs the current errors messages that keeps repeating itself everytime a new action is ran :

Exception: Exception while performing Work::Cron::RefreshFritoPieContentSources.perform()!: Swiftype::ES::ReadOnlyModeWriteError: index [.ent-search-db-lock] blocked by: [TOO_MANY_REQUESTS/12/disk usage exceeded flood-stage watermark, index has read-only-allow-delete block];

It looks like App search is putting my indexes in readonly due to a small amount of disk space.

I've seen online that there are some command lines :
curl -X PUT -H "Content-Type: application/json" -d '{"index.blocks.read_only_allow_delete": null}

but these are for Elasticsearch, so I don't know if I can use it here as App-search uses Elasticsearch too...

Hi @Nagib! :wave:

I think Elasticsearch is blocking writes because of low disk space and App Search interpreting it as read-only mode. I would try to solve this problem on the Elasticsearch side.

Also found this post, maybe it'll help: Elasticsearch Docker: flood stage disk watermark [95%] exceeded

Hi @Vadim_Yakhin , I ran this command :

curl -XPUT -H "Content-Type: application/json" http://localhost:9200/_all/_settings -d '{"index.blocks.read_only_allow_delete": null}'
and it seems to have solved the problem, thank you for the help !

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.