How to hide error message for graphs

{
  "$schema": "https://vega.github.io/schema/vega-lite/v4.json",
  "description": "A simple bar chart with embedded data.",
  "data": {
    "values": [
      {"a": "A", "b": 28}, {"a": "B", "b": 55}, {"a": "C", "b": 43},
      {"a": "D", "b": 91}, {"a": "E", "b": 81}, {"a": "F", "b": 53},
      {"a": "G", "b": 19}, {"a": "H", "b": 87}, {"a": "I", "b": 52}
    ]
  },
  "transform":[  {"filter": "datum.a == 'N'"}]
  "mark": "bar",
  "encoding": {
    "x": {"field": "a", "type": "nominal", "axis": {"labelAngle": 0}},
    "y": {"field": "b", "type": "quantitative"}
  }
}

Output :

Is there any way to hide this error message?

Hi, the warning message is actually displayed directly by Vega and we don't have a way in Kibana to disable it.
It logically describe that there is an issue with your current vega spec: the Y channel need an extent to render bars, with the filter applied you don't have data and the extent is basically [Infinity, -Infinity]
I'm checking if this issue will be solved in 7.11 or in a 7.10 patch release, but it depends on vega if this warning can be dismissed or removed completely. Testing it on the latest vega-lite version doesn't seems to result in a warning message, so probably a library update can fix this in a new Kibana release