How to index file have content json with FSCrawler

I have file json(/tmp/es/ecep_elib_table_books.json) with content:

I config file /_default/6/_settings.json

I config file _settings.json into my job
When I run bin/fscrawler --config_dir ./demo_01 demo_01 --restart, I get error

I hope someone can help my fix it :frowning:


Please don't post images of text as they are hard to read, may not display correctly for everyone, and are not searchable.

Instead, paste the text and format it with </> icon or pairs of triple backticks (```), and check the preview window to make sure it's properly formatted before posting it. This makes it more likely that your question will receive a useful answer.

It would be great if you could update your post to solve this.

Here the main issue is that your JSON file contains actually an array of JSON documents not a single JSON document.
If you want to use FSCrawler, you need to have one single file per json document.
A Json document should always start with {.

Sorry, I will learn from experience next time.
The great thing is that I solved the problem above.
Thank bro.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.