How to install logstash-output-solr plugin in logstash 5.5


(sri) #1

how to install logstash-output-solr plugin in logstash 5.5.pls help


(Magnus Bäck) #2

What have you tried? What were the results?


(sri) #3

Hi

Thanks for the response.
pls see below wht i have tried

i have cloned from link:
:https://github.com/mosuka/logstash-output-solr
Built the gem file using
gem build logstash-output-lucidworks_solr.gemspec
WARNING: license value 'Apache License (2.0)' is invalid. Use a license identifier from
http://spdx.org/licenses or 'Nonstandard' for a nonstandard license.
Did you mean 'Apache-2.0'?
WARNING: open-ended dependency on logstash-codec-plain (>= 0) is not recommended
if logstash-codec-plain is semantically versioned, use:
add_runtime_dependency 'logstash-codec-plain', '~> 0'
WARNING: open-ended dependency on logstash-devutils (>= 0, development) is not recommended
if logstash-devutils is semantically versioned, use:
add_development_dependency 'logstash-devutils', '~> 0'
WARNING: See http://guides.rubygems.org/specification-reference/ for help
Successfully built RubyGem
Name: logstash-output-lucidworks_solr
Version: 1.3.3
File: logstash-output-lucidworks_solr-1.3.3.gem

used this gem file to install the plugin as follows:

/usr/share/logstash$ bin/logstash-plugin install logstash-output-lucidworks_solr-1.3.3.gem
Validating logstash-output-lucidworks_solr-1.3.3.gem
Installing logstash-output-lucidworks_solr
Plugin version conflict, aborting
ERROR: Installation Aborted, message: Bundler could not find compatible versions for gem "logstash-core":
In snapshot (Gemfile.lock):
logstash-core (= 5.0.0.pre.alpha5)

In Gemfile:
logstash-core-plugin-api (>= 0) java depends on
logstash-core (= 5.0.0.pre.alpha5) java

logstash-output-solr (>= 0) java depends on
  logstash-core (< 3.0.0, >= 2.0.0) java

logstash-core (>= 0) java

Running bundle update will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.
qolsys@soumya:/usr/share/logstash$ bundle update

[!] There was an error while loading logstash-core-plugin-api.gemspec: The logstash-core-api need to be build on jruby. Bundler cannot continue.

from /usr/share/logstash/logstash-core-plugin-api/logstash-core-plugin-api.gemspec:27

-------------------------------------------

else

 raise "The logstash-core-api need to be build on jruby"

end

-------------------------------------------

I am trying to install it on the logstash 5.5 version.unable to solve version conflicts.
pls help
soumya


(Magnus Bäck) #4

Here's the line that prevents the installation:

Try replacing it with this:

s.add_runtime_dependency "logstash-core-plugin-api", ">= 2.0.0", "< 2.99"

(sri) #5

Hi magnusbaeck

Thanks for the response.I would definitely try the suggested solution and report back to you .

CAn you also confirm that this is the plugin required to send data to solr cloud in production mode.

Thankyou
soumya


(Magnus Bäck) #6

CAn you also confirm that this is the plugin required to send data to solr cloud in production mode.

I don't know anything about that plugin or what you mean by "production mode".


(sri) #7

ok...I will try the installation as stated by you..


(sri) #8

I am getting the below error again:

/usr/share/logstash$ bin/logstash-plugin install /home/qolsys/Desktop/28Aug/logstash-output-solr-master/logstash-output-solr-0.3.0.gem
Validating /home/qolsys/Desktop/28Aug/logstash-output-solr-master/logstash-output-solr-0.3.0.gem
Installing logstash-output-solr
Plugin not found, aborting
ERROR: Installation Aborted, message: Could not find gem 'logstash-core-plugin-api (>= 0) java' in source at ./logstash-core-plugin-api.
Source contains 'logstash-core-plugin-api' at: 2.1.10


(sri) #9

also can you pls let me know if logstash-output-solr plugin is supported by logstash5.5 an d above versions


(sri) #10

any update pls


(system) #11

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.