Compile logstash-output-elasticsearch


(Peter G. Marczis) #1

Hello everyone !
First of all thanks a lot for your great products !
I have an add-on idea for logstash-output-elasticsearch plugin, but I don't manage to compile / install the plugin... I really read the instructions but, now I'm stuck. Any help would be nice :smile:
So what I have:
logstash 1.5.1

I tried to install the output plugin from: origin/bump_version branch, as only this one was okay with the dependencies. I'm not sure if this is the right branch. If I use the master, than 1.5.1 is not recent enough (elasticsearch is older than master expects... as far as I understand ruby & gems).

So with this branch + version I manage to install the plugin like this:

bin/plugin install /root/logstash-output-elasticsearch-0.1.6.gem 
Validating /root/logstash-output-elasticsearch-0.1.6.gem
Installing logstash-output-elasticsearch

jar dependencies found on non-java platform gem - do not install jars

Installation successful

So looks okay, expect that jars are not installed... well they should be there as I had the given plugin installed by default. Or not ?
And so when I startup the logstash I get:

/opt/logstash/bin/logstash -f /etc/logstash/conf.d -l /mnt/log/logstash/logstash.log
Sending logstash logs to /mnt/log/logstash/logstash.log.
The error reported is: 
  Couldn't find any output plugin named 'elasticsearch'. Are you sure this is correct? Trying to load the elasticsearch output plugin resulted in this error: no such file to load -- logstash-output-elasticsearch_jars

And that's right I don't have any plugin called logstash-output-elasticsearch_jars, but of course I can't just install this....

Thanks a lot in advance !
Br,
Peter.


(Mert Nuhoglu) #2

Did you find the solution to this problem?


(Peter G. Marczis) #3

To be honest, I don't remember what was the outcome... but I definitely solved the whole thing, as the system is up and running :slight_smile:


(system) #4