Cannot build logstash-output-elasticsearch plugin locally

I'm attempting to build this plugin locally:

However it fails seemingly due to a gemspec dependency issue:

logstash-output-elasticsearch % jruby -S bundle install
Fetching gem metadata from https://rubygems.org/.........
Resolving dependencies.....................
Bundler could not find compatible versions for gem "logstash-core":
  In Gemfile:
    logstash-output-elasticsearch was resolved to 11.22.2, which depends on
logstash-core-plugin-api (>= 1.60, <= 2.99) was resolved to 1.60.1, which
depends on
        logstash-core (<= 2.4.99, >= 2.4.0.snapshot1)
    logstash-output-elasticsearch was resolved to 11.22.2, which depends on
logstash-mixin-deprecation_logger_support (~> 1.0) was resolved to 1.0.0,
which depends on
        logstash-core (>= 5.0.0)

Has anyone managed to build this plugin locally themselves?

I assume as this plugin is being released frequently it must be being built internally somehow, but perhaps there is some difference in my jruby/gem/bundler versions which affects the dependency resolution:

jruby -version
jruby 9.4.5.0 (3.1.4) 2023-11-02 1abae2700f OpenJDK 64-Bit Server VM 21.0.2 on 21.0.2 +jit [arm64-darwin]
bundle --version
Bundler version 2.3.26

I've also attempted the same, with the same failure in a jruby:9-jdk docker image.

I've opened an issue here: Cannot bundle install due to gemspec deps · Issue #1166 · logstash-plugins/logstash-output-elasticsearch · GitHub but any insight or tips would be appreciated.