Unable to build logstash-input-tcp - compatible versions for gem "logstash-core"

Hi Team,

I'm trying to build logstash-input-tcp plugin. It is failing with the following error. Exception is showing as compatible versions for gem "logstash-core".

ENV details:
Centos Stream
JAVA: javac 11.0.14
Jruby: =* jruby- [ x86_64 ]


git clone -b v6.2.6 GitHub - logstash-plugins/logstash-input-tcp
bundle install


bundle install
Your RubyGems version (2.7.10)) has a bug that prevents `required_ruby_version` from working for Bundler. Any scripts that use `gem install bundler` will break as soon as Bundler drops support for your Ruby version. Please upgrade RubyGems to avoid future breakage and silence this warning by running `gem update --system 3.2.3`
Don't run Bundler as root. Bundler can ask for sudo if it is needed, and
installing your bundle as root will break this application for all non-root
users on this machine.
Fetching gem metadata from https://rubygems.org/........
Resolving dependencies.....................
Bundler could not find compatible versions for gem "logstash-core":
  In Gemfile:
    logstash-input-tcp was resolved to 6.2.6, which depends on
logstash-core-plugin-api (>= 1.60, <= 2.99) was resolved to 1.60.1, which
depends on
        logstash-core (>= 2.4.0.snapshot1, <= 2.4.99)

    logstash-input-tcp was resolved to 6.2.6, which depends on
      logstash-core (>= 6.7.0)

@ pebrc
Can you please help here or direct to concerned team

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.