Shield install for logstash

security

(Rohan Jain) #1

it is required to configure logstash elasticsearch output for shield.
For that the command to run is : => bin/plugin install logstash-output-elasticsearch-shield

After running this command i am getting error
"
Validating logstash-output-elasticsearch-shield
Installing logstash-output-elasticsearch-shield
Plugin version conflict, aborting
ERROR: Installation Aborted, message: Bundler could not find compatible versions for gem "logstash-output-elasticsearch":
In snapshot (Gemfile.lock):
logstash-output-elasticsearch (= 2.5.1)

In Gemfile:
logstash-output-elasticsearch-shield (>= 0) java depends on
logstash-output-elasticsearch (<= 0.1.9) java

logstash-output-elasticsearch (>= 0) java

Running bundle update will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.
"

After this i searched this error on google but dint get any solution unfortunately.
After that tried to run => bundle update

But again i am getting error

Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/...
Fetching dependency metadata from https://rubygems.org/..
Could not find gem 'logstash-core (= 2.2.2) ruby' in any of the gem sources listed in your Gemfile or available on this machine

Can anyone provide me with solution for this


(Alvin Chen) #2

Hi Rohan - what protocol are you intending to use? The HTTP protocol is now default and recommended for the Elasticsearch output. With HTTP, the separate ES-shield output plugin isn't required; you just need to add a few options in the ES output portion of your config.


(andrewvc) #3

This is the wrong plugin, you want logstash-output-elasticsearch_java-shield . You'll want to use that with the logstash-output-elasticsearch_java plugin. logstash-output-elasticsearch-shield is for old versions of logstash / shield.

This should work with ES2.x+


(system) #4