Logstash-syslog-output install issues

I ran the following command:

sudo gem install logstash-output-syslog

Get the errors below:
ERROR: Could not find a valid gem 'logstash-core-plugin-api' (<= 2.99, >= 1.60) in any repository
ERROR: Possible alternatives: ph-logstash-core-plugin-api, logstash-codec-line, logstash-codec-plain, logstash-codec-fluent, logstash-codec-lineeof

I tried to install the possible alternatives it suggested, but got the same error.
I'm not sure how to fix this issue.
Any help is much appreciated.

Another member of my team figured out how to make this work correctly.
Using the command below:
/usr/share/logstash# jruby -S gem install logstash-output-syslog
Fetching: logstash-codec-plain-3.0.3.gem (100%)
Successfully installed logstash-codec-plain-3.0.3
Fetching: logstash-output-syslog-3.0.2.gem (100%)
Successfully installed logstash-output-syslog-3.0.2
2 gems installed

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.