How to make my index default index pattern


(Jas Ahluwalia) #1

Hi,

I have the following in my logstash.conf file:

 output {
 	elasticsearch {
  		hosts => "elasticsearch:9200"
        index => "myIndex-%{+YYYY.MM.dd}"
  	}
}

How can I get myIndex to be the default index in kibana? Right now I still have to create the index pattern myIndex-* and set timestamp. I'd like to have that ready to go out of the box.

Apologies if this is more a kibana question or elasticsearch question, but I'll start here as these settings are in logstash.conf.

Thanks,
Jas


(Magnus B├Ąck) #2

How can I get myIndex to be the default index in kibana? Right now I still have to create the index pattern myIndex-* and set timestamp. I'd like to have that ready to go out of the box.

I suggest you ask that question in the Kibana category. Logstash can't affect that.

(Also, index names can't contain uppercase letters.)


(Jas Ahluwalia) #3

Hi,

Thanks, I'll repost there.

and yes, I mistyped my index here as I didn't want to include the actual name.

thanks,
jas


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.