How to pipeline.yml - I'm stuck

Hi There,

due to the original documentation does not help,
I hope you could!

I have a logstash conf file.
That works fine as Standalone.
Now I have 3 files which I want to index

These 3 files are different, so each have its own conf file to transform in different ways.
However! I like to Index all 3 via logstash pipeline.yml

- ps
  pipeline.workers: 1
  pipeline.batch.size: 1
  path.config: "/Logstash/bin/_ps_logstash_1.conf"
- so
  pipeline.workers: 1
  pipeline.batch.size: 1
  path.config: "/Logstash/bin/_so_logstash_1.conf"
- va
  pipeline.workers: 1
  pipeline.batch.size: 1
  path.config: "/Logstash/bin/_va_logstash_1.conf"

....nothing more here, for first steps to understand how to.

I run logstash.bat (no -e or -f)

Sending Logstash logs to C:/Logstash/logs which is now configured via
ERROR: Failed to read pipelines yaml file. Location: C:/Logstash/config/pipelines.yml
bin/logstash -f CONFIG_PATH [-t] [-r] [-w COUNT] [-l LOG]
bin/logstash -e CONFIG_STR [-t] [--log.level fatal|error|warn|info|debug|trace] [-w COUNT] [-l LOG]
bin/logstash -i SHELL [--log.level fatal|error|warn|info|debug|trace]
bin/logstash -V [--log.level fatal|error|warn|info|debug|trace]
bin/logstash --help
[2019-01-22T15:34:47,566][ERROR][org.logstash.Logstash ] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

Why? Because the file is there!
I tried with \ and /

Thanks and Regards

@Datakids, that's the error Logstash returns when it either cannot find the pipelines.yml file in the expected directory or does not have permissions to read the file. Verify that C:/Logstash/config/pipelines.yml exists and that the user account under which you're running Logstash has permissions to read that file.

thanks for reply!
Thats the common installed file I used in this path!
I use my local pc! There is no restricted permisssions to nothing thats why I'm wondering!

Logstash would return a different error if it found the pipelines.yml but was unable to successfully read it, so that's why I think it's a problem with a missing file or insufficient permissions. Offhand, I don't know what else to suggest besides possibly increasing the logging verbosity to see if any additional troubleshooting data is available in the debug logs.

I will try to check the settings.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.