How to reindex


#1

Apologies if this has already been asked. I was not able to find
references. I had to update the settings on my index.

curl -XPUT 'http://localhost:9200/test1/_settings' -d '{
"index": {
"analysis" :{
"analyzer": {
"default": {
"type" : "custom",
"tokenizer" : "uax_url_email",
"filter" : ["standard", "stop"]
}
}
}
}
}
'

Now how do I kickstart the reindexing process ?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

Remove your type (it will remove all your docs)
Put the mapping using the PUT Mapping API
Send again all your docs

Is it what you were looking for?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 10 avr. 2013 à 07:44, avinsemail@gmail.com a écrit :

Apologies if this has already been asked. I was not able to find references. I had to update the settings on my index.

curl -XPUT 'http://localhost:9200/test1/_settings' -d '{
"index": {
"analysis" :{
"analyzer": {
"default": {
"type" : "custom",
"tokenizer" : "uax_url_email",
"filter" : ["standard", "stop"]
}
}
}
}
}
'

Now how do I kickstart the reindexing process ?

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


#3

I dont want to recreate the index and send in all the docs again. The
limitation being I dont have any of the docs which have already indexed. Is
there any other way redo the indexing ?

On Tuesday, April 9, 2013 11:39:44 PM UTC-7, David Pilato wrote:

Remove your type (it will remove all your docs)
Put the mapping using the PUT Mapping API
Send again all your docs

Is it what you were looking for?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 10 avr. 2013 à 07:44, avins...@gmail.com <javascript:> a écrit :

Apologies if this has already been asked. I was not able to find
references. I had to update the settings on my index.

curl -XPUT 'http://localhost:9200/test1/_settings' -d '{
"index": {
"analysis" :{
"analyzer": {
"default": {
"type" : "custom",
"tokenizer" : "uax_url_email",
"filter" : ["standard", "stop"]
}
}
}
}
}
'

Now how do I kickstart the reindexing process ?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(ppearcy) #4

In that case you need to create a new index and index into that one. This
plugin should help:

Using index aliasing should allow you to do this seamlessly and swap the
aliases to make the new one live.

Best Regards,
Paul

On Wednesday, April 10, 2013 11:04:14 AM UTC-6, avins...@gmail.com wrote:

I dont want to recreate the index and send in all the docs again. The
limitation being I dont have any of the docs which have already indexed. Is
there any other way redo the indexing ?

On Tuesday, April 9, 2013 11:39:44 PM UTC-7, David Pilato wrote:

Remove your type (it will remove all your docs)
Put the mapping using the PUT Mapping API
Send again all your docs

Is it what you were looking for?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 10 avr. 2013 à 07:44, avins...@gmail.com a écrit :

Apologies if this has already been asked. I was not able to find
references. I had to update the settings on my index.

curl -XPUT 'http://localhost:9200/test1/_settings' -d '{
"index": {
"analysis" :{
"analyzer": {
"default": {
"type" : "custom",
"tokenizer" : "uax_url_email",
"filter" : ["standard", "stop"]
}
}
}
}
}
'

Now how do I kickstart the reindexing process ?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Eric) #5

@ppearcy Wait. You can't take an elasticsearch input and output it to the same index?


(system) #6