Change "search_analyzer" settings without reindexing


(paul) #1

hi ,

Is there a way to change search analyzer settings without re-indexing the
entire data. I am experimenting with various configuration and every time i
change the setting i am re-indexing.

setting:

    "autocomplete_search":{
           "type":"custom",
           "tokenizer":"my_pipe_analyzer",
           "filter":[
              "lowercase",
              "syns_filter",

"stop"
]
},
"autocomplete_index":{
"type":"custom",
"tokenizer":"standard",
"filter":[
"standard",
"lowercase",
"syns_filter",
"stop",
"my_edgeNgram"
]
}
mapping:

        "name":{
           "type":"string",
   "index_analyzer" : "autocomplete_index", 
   "search_analyzer" : "autocomplete_search"
        },

-paul

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/97baca09-4d0f-4f70-b654-68510885e9e4%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

I don't think it will work but you can set the analyzer you want at query time: http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/query-dsl-match-query.html#_boolean:
The analyzer can be set to control which analyzer will perform the analysis process on the text. It default to the field explicit mapping definition, or the default search analyzer.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 20 janv. 2014 à 06:22, paul avinashpaul85@gmail.com a écrit :

hi ,

Is there a way to change search analyzer settings without re-indexing the entire data. I am experimenting with various configuration and every time i change the setting i am re-indexing.

setting:

    "autocomplete_search":{
           "type":"custom",
           "tokenizer":"my_pipe_analyzer",
           "filter":[
              "lowercase",
              "syns_filter",
	  "stop"
           ]
        },
        "autocomplete_index":{
           "type":"custom",
           "tokenizer":"standard",
           "filter":[
              "standard",
              "lowercase",
              "syns_filter",
	  "stop",
              "my_edgeNgram"
           ]
        }

mapping:

        "name":{
           "type":"string",
       "index_analyzer" : "autocomplete_index", 
       "search_analyzer" : "autocomplete_search"
        },

-paul

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/97baca09-4d0f-4f70-b654-68510885e9e4%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6BDDE4F6-363F-467F-903B-0938AA1B16F4%40pilato.fr.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #3