How to resolve red cluster status after trying to add a new node

Hi All,

I had a three nodes ES cluster running fine and I tried to add a new node
to the cluster. I took down one node, and put the new node into the cluster
with other two nodes and hopefully the new node will get the data
replicated. But I could not get the cluster status to green - it could only

"unassigned_shards": 5

with a YELLOW status after many tries.

Then I tried to put back the original node to the cluster and try to get
back to working state. Now I got:

"unassigned_shards": 10

With a RED status!

Assuming I could afford some data loss, how would I get the cluster back to

Is there any way we could resolve the RED cluster state without losing data
in this situation?

Why adding a new node to the cluster stuck at the yellow state?

I am running ES 1.4.2

I appreciate all helps!


You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
To view this discussion on the web visit
For more options, visit