How to resolve the index missing exception

Hi All,

i have used in windows system to search based on text using elastic
search java api..it is working.. when i moved it into linux i am getting
index not found exception..

[dc_user_idx] missing

is there any thing missing.?

this is java code:

Node node = NodeBuilder.nodeBuilder().client(true).node();
Client client = node.client();
SearchResponse response = null;

    response = 

client.prepareSearch().setQuery(QueryBuilders.queryString(""+searchText+"").field("userName").field("firstName").field("displayName").field("lastName").field("email").field("phoneNumber").field("alternativeContact").field("office").field("practice").field("role").field("additionalFields").field("createdBy").field("modifiedBy")).setIndices("dc_user_idx")
.setTypes("DC_USER").execute().actionGet();
SearchHit[] results = response.getHits().getHits();

for (SearchHit hit : results) {
result.put(""+count, hit.getSource()); // the retrieved document
list.add(hit.getSource());
}

http://10.0.0.12:9200/_river/dc_user_river/_status?pretty=true

output:

{
"_index" : "_river",
"_type" : "dc_user_river",
"_id" : "_status",
"_version" : 2,
"exists" : true, "_source" : {"ok":true,"node":{"id":"k54i3bPZRiKvtsrWCqXbPg","name":"Vengeance","transport_address":"inet[/10.0.0.12:9300]"}}
}

http://10.0.0.12:9200/_cluster/health?pretty=true

{
"cluster_name" : "DC_Cluster",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 91,
"active_shards" : 91,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 91
}
can one help me..

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Can you curl http://10.0.0.12:9200/dc_user_idx/_status

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 18 mars 2013 à 08:45, srikanth gone srikanthg93@gmail.com a écrit :

Hi All,

i have used in windows system to search based on text using elastic search java api..it is working.. when i moved it into linux i am getting index not found exception..
[dc_user_idx] missing

is there any thing missing.?

this is java code:

Node node = NodeBuilder.nodeBuilder().client(true).node();
Client client = node.client();
SearchResponse response = null;

    response = client.prepareSearch().setQuery(QueryBuilders.queryString("*"+searchText+"*").field("userName").field("firstName").field("displayName").field("lastName").field("email").field("phoneNumber").field("alternativeContact").field("office").field("practice").field("role").field("additionalFields").field("createdBy").field("modifiedBy")).setIndices("dc_user_idx")
    .setTypes("DC_USER").execute().actionGet();

SearchHit[] results = response.getHits().getHits();

for (SearchHit hit : results) {
result.put(""+count, hit.getSource()); // the retrieved document
list.add(hit.getSource());
}

http://10.0.0.12:9200/_river/dc_user_river/_status?pretty=true

output:

{
"_index" : "_river",
"_type" : "dc_user_river",
"_id" : "_status",
"_version" : 2,
"exists" : true, "_source" : {"ok":true,"node":{"id":"k54i3bPZRiKvtsrWCqXbPg","name":"Vengeance","transport_address":"inet[/10.0.0.12:9300]"}}
}

http://10.0.0.12:9200/_cluster/health?pretty=true

{
"cluster_name" : "DC_Cluster",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 91,
"active_shards" : 91,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 91
}
can one help me..

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hi David..

i getting this output: only 5 shards are getting success..

{
"ok" : true,
"_shards" : {
"total" : 10,
"successful" : 5,
"failed" : 0
},
"indices" : {
"dc_user_idx" : {
"index" : {
"primary_size" : "305.8kb",
"primary_size_in_bytes" : 313183,
"size" : "305.8kb",
"size_in_bytes" : 313183
},
"translog" : {
"operations" : 354
},
"docs" : {
"num_docs" : 350,
"max_doc" : 352,
"deleted_docs" : 2
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 12,
"total_time" : "149ms",
"total_time_in_millis" : 149
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
},
"shards" : {
"0" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 0,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "68.6kb",
"size_in_bytes" : 70261
},
"translog" : {
"id" : 1363601429673,
"operations" : 79
},
"docs" : {
"num_docs" : 79,
"max_doc" : 79,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 3,
"total_time" : "26ms",
"total_time_in_millis" : 26
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"1" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 1,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "73.8kb",
"size_in_bytes" : 75662
},
"translog" : {
"id" : 1363601429734,
"operations" : 87
},
"docs" : {
"num_docs" : 87,
"max_doc" : 87,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 3,
"total_time" : "41ms",
"total_time_in_millis" : 41
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"2" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 2,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "63.2kb",
"size_in_bytes" : 64776
},
"translog" : {
"id" : 1363601430455,
"operations" : 73
},
"docs" : {
"num_docs" : 73,
"max_doc" : 73,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "19ms",
"total_time_in_millis" : 19
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"3" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 3,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "46.1kb",
"size_in_bytes" : 47292
},
"translog" : {
"id" : 1363601429801,
"operations" : 53
},
"docs" : {
"num_docs" : 51,
"max_doc" : 52,
"deleted_docs" : 1
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "20ms",
"total_time_in_millis" : 20
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"4" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 4,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "53.8kb",
"size_in_bytes" : 55192
},
"translog" : {
"id" : 1363601429868,
"operations" : 62
},
"docs" : {
"num_docs" : 60,
"max_doc" : 61,
"deleted_docs" : 1
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "43ms",
"total_time_in_millis" : 43
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ]
}
}
}
}

On Monday, March 18, 2013 2:51:59 PM UTC+5:30, David Pilato wrote:

Can you curl http://10.0.0.12:9200/dc_user_idx/_status

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 18 mars 2013 à 08:45, srikanth gone <srika...@gmail.com <javascript:>>
a écrit :

Hi All,

i have used in windows system to search based on text using elastic
search java api..it is working.. when i moved it into linux i am getting
index not found exception..

[dc_user_idx] missing

is there any thing missing.?

this is java code:

Node node = NodeBuilder.nodeBuilder().client(true).node();
Client client = node.client();
SearchResponse response = null;

    response = 

client.prepareSearch().setQuery(QueryBuilders.queryString(""+searchText+"").field("userName").field("firstName").field("displayName").field("lastName").field("email").field("phoneNumber").field("alternativeContact").field("office").field("practice").field("role").field("additionalFields").field("createdBy").field("modifiedBy")).setIndices("dc_user_idx")
.setTypes("DC_USER").execute().actionGet();
SearchHit[] results = response.getHits().getHits();

for (SearchHit hit : results) {
result.put(""+count, hit.getSource()); // the retrieved document
list.add(hit.getSource());
}

http://10.0.0.12:9200/_river/dc_user_river/_status?pretty=true

output:

{
"_index" : "_river",
"_type" : "dc_user_river",
"_id" : "_status",
"_version" : 2,
"exists" : true, "_source" : {"ok":true,"node":{"id":"k54i3bPZRiKvtsrWCqXbPg","name":"Vengeance","transport_address":"inet[/10.0.0.12:9300]"}}
}

http://10.0.0.12:9200/_cluster/health?pretty=true

{
"cluster_name" : "DC_Cluster",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 91,
"active_shards" : 91,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 91
}
can one help me..

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Are you sure you are joining the cluster in Java?
What do you see in Java logs?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 18 mars 2013 à 11:11, srikanth gone srikanthg93@gmail.com a écrit :

Hi David..

i getting this output: only 5 shards are getting success..

{
"ok" : true,
"_shards" : {
"total" : 10,
"successful" : 5,
"failed" : 0
},
"indices" : {
"dc_user_idx" : {
"index" : {
"primary_size" : "305.8kb",
"primary_size_in_bytes" : 313183,
"size" : "305.8kb",
"size_in_bytes" : 313183
},
"translog" : {
"operations" : 354
},
"docs" : {
"num_docs" : 350,
"max_doc" : 352,
"deleted_docs" : 2
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 12,
"total_time" : "149ms",
"total_time_in_millis" : 149
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
},
"shards" : {
"0" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 0,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "68.6kb",
"size_in_bytes" : 70261
},
"translog" : {
"id" : 1363601429673,
"operations" : 79
},
"docs" : {
"num_docs" : 79,
"max_doc" : 79,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 3,
"total_time" : "26ms",
"total_time_in_millis" : 26
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"1" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 1,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "73.8kb",
"size_in_bytes" : 75662
},
"translog" : {
"id" : 1363601429734,
"operations" : 87
},
"docs" : {
"num_docs" : 87,
"max_doc" : 87,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 3,
"total_time" : "41ms",
"total_time_in_millis" : 41
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"2" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 2,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "63.2kb",
"size_in_bytes" : 64776
},
"translog" : {
"id" : 1363601430455,
"operations" : 73
},
"docs" : {
"num_docs" : 73,
"max_doc" : 73,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "19ms",
"total_time_in_millis" : 19
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"3" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 3,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "46.1kb",
"size_in_bytes" : 47292
},
"translog" : {
"id" : 1363601429801,
"operations" : 53
},
"docs" : {
"num_docs" : 51,
"max_doc" : 52,
"deleted_docs" : 1
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "20ms",
"total_time_in_millis" : 20
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"4" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 4,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "53.8kb",
"size_in_bytes" : 55192
},
"translog" : {
"id" : 1363601429868,
"operations" : 62
},
"docs" : {
"num_docs" : 60,
"max_doc" : 61,
"deleted_docs" : 1
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "43ms",
"total_time_in_millis" : 43
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ]
}
}
}
}

On Monday, March 18, 2013 2:51:59 PM UTC+5:30, David Pilato wrote:
Can you curl http://10.0.0.12:9200/dc_user_idx/_status

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 18 mars 2013 à 08:45, srikanth gone srika...@gmail.com a écrit :

Hi All,

i have used in windows system to search based on text using elastic search java api..it is working.. when i moved it into linux i am getting index not found exception..
[dc_user_idx] missing

is there any thing missing.?

this is java code:

Node node = NodeBuilder.nodeBuilder().client(true).node();
Client client = node.client();
SearchResponse response = null;

    response = client.prepareSearch().setQuery(QueryBuilders.queryString("*"+searchText+"*").field("userName").field("firstName").field("displayName").field("lastName").field("email").field("phoneNumber").field("alternativeContact").field("office").field("practice").field("role").field("additionalFields").field("createdBy").field("modifiedBy")).setIndices("dc_user_idx")
    .setTypes("DC_USER").execute().actionGet();

SearchHit[] results = response.getHits().getHits();

for (SearchHit hit : results) {
result.put(""+count, hit.getSource()); // the retrieved document
list.add(hit.getSource());
}

http://10.0.0.12:9200/_river/dc_user_river/_status?pretty=true

output:

{
"_index" : "_river",
"_type" : "dc_user_river",
"_id" : "_status",
"_version" : 2,
"exists" : true, "_source" : {"ok":true,"node":{"id":"k54i3bPZRiKvtsrWCqXbPg","name":"Vengeance","transport_address":"inet[/10.0.0.12:9300]"}}
}

http://10.0.0.12:9200/_cluster/health?pretty=true

{
"cluster_name" : "DC_Cluster",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 91,
"active_shards" : 91,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 91
}
can one help me..

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

in elasticsearch.yml

i have given clustername =MyCluster

network:
host: 10.0.0.12

and es.properties

Node test setup

cluster.name=dc-cluster
name=junit.node

Disable network

discovery.zen.ping.multicast.enabled=false
node.local=true
#transport.tcp.port=9300-9400
#discovery.zen.ping.unicast.hosts=localhost

Using less filesystem as possible

index.store.type=memory
index.store.fs.memory.enabled=true
index.gateway.type=none
gateway.type=none

If ES needs to write something, it's here

path.data=/es/twitter

Index are minimalists by default

index.number_of_shards=0
index.number_of_replicas=1

in java..
Node node = NodeBuilder.nodeBuilder().client(true).node();
Client client = node.client();
is there any thing is missing

On Monday, March 18, 2013 3:43:38 PM UTC+5:30, David Pilato wrote:

Are you sure you are joining the cluster in Java?
What do you see in Java logs?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 18 mars 2013 à 11:11, srikanth gone <srika...@gmail.com <javascript:>>
a écrit :

Hi David..

i getting this output: only 5 shards are getting success..

{
"ok" : true,
"_shards" : {
"total" : 10,
"successful" : 5,
"failed" : 0
},
"indices" : {
"dc_user_idx" : {
"index" : {
"primary_size" : "305.8kb",
"primary_size_in_bytes" : 313183,
"size" : "305.8kb",
"size_in_bytes" : 313183
},
"translog" : {
"operations" : 354
},
"docs" : {
"num_docs" : 350,
"max_doc" : 352,
"deleted_docs" : 2
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 12,
"total_time" : "149ms",
"total_time_in_millis" : 149
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
},
"shards" : {
"0" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 0,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "68.6kb",
"size_in_bytes" : 70261
},
"translog" : {
"id" : 1363601429673,
"operations" : 79
},
"docs" : {
"num_docs" : 79,
"max_doc" : 79,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 3,
"total_time" : "26ms",
"total_time_in_millis" : 26
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"1" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 1,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "73.8kb",
"size_in_bytes" : 75662
},
"translog" : {
"id" : 1363601429734,
"operations" : 87
},
"docs" : {
"num_docs" : 87,
"max_doc" : 87,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 3,
"total_time" : "41ms",
"total_time_in_millis" : 41
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"2" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 2,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "63.2kb",
"size_in_bytes" : 64776
},
"translog" : {
"id" : 1363601430455,
"operations" : 73
},
"docs" : {
"num_docs" : 73,
"max_doc" : 73,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "19ms",
"total_time_in_millis" : 19
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"3" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 3,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "46.1kb",
"size_in_bytes" : 47292
},
"translog" : {
"id" : 1363601429801,
"operations" : 53
},
"docs" : {
"num_docs" : 51,
"max_doc" : 52,
"deleted_docs" : 1
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "20ms",
"total_time_in_millis" : 20
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"4" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 4,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "53.8kb",
"size_in_bytes" : 55192
},
"translog" : {
"id" : 1363601429868,
"operations" : 62
},
"docs" : {
"num_docs" : 60,
"max_doc" : 61,
"deleted_docs" : 1
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "43ms",
"total_time_in_millis" : 43
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ]
}
}
}
}

On Monday, March 18, 2013 2:51:59 PM UTC+5:30, David Pilato wrote:

Can you curl http://10.0.0.12:9200/dc_user_idx/_status

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 18 mars 2013 à 08:45, srikanth gone srika...@gmail.com a écrit :

Hi All,

i have used in windows system to search based on text using elastic
search java api..it is working.. when i moved it into linux i am getting
index not found exception..

[dc_user_idx] missing

is there any thing missing.?

this is java code:

Node node = NodeBuilder.nodeBuilder().client(true).node();
Client client = node.client();
SearchResponse response = null;

    response = 

client.prepareSearch().setQuery(QueryBuilders.queryString(""+searchText+"").field("userName").field("firstName").field("displayName").field("lastName").field("email").field("phoneNumber").field("alternativeContact").field("office").field("practice").field("role").field("additionalFields").field("createdBy").field("modifiedBy")).setIndices("dc_user_idx")
.setTypes("DC_USER").execute().actionGet();
SearchHit[] results = response.getHits().getHits();

for (SearchHit hit : results) {
result.put(""+count, hit.getSource()); // the retrieved document
list.add(hit.getSource());
}

http://10.0.0.12:9200/_river/dc_user_river/_status?pretty=true

output:

{
"_index" : "_river",
"_type" : "dc_user_river",
"_id" : "_status",
"_version" : 2,
"exists" : true, "_source" : {"ok":true,"node":{"id":"k54i3bPZRiKvtsrWCqXbPg","name":"Vengeance","transport_address":"inet[/10.0.0.12:9300]"}}
}

http://10.0.0.12:9200/_cluster/health?pretty=true

{
"cluster_name" : "DC_Cluster",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 91,
"active_shards" : 91,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 91
}
can one help me..

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

this is java code:

Node node = NodeBuilder.nodeBuilder().
client(true).node();
Client client = node.client();
SearchResponse response = null;

    response = 

client.prepareSearch().setQuery(QueryBuilders.queryString(""+searchText+"").field("userName").field("firstName").field("displayName").field("lastName").field("email").field("phoneNumber").field("alternativeContact").field("office").field("practice").field("role").field("additionalFields").field("createdBy").field("modifiedBy")).setIndices("dc_user_idx")
.setTypes("DC_USER").execute().actionGet();
SearchHit[] results = response.getHits().getHits();

for (SearchHit hit : results) {
result.put(""+count, hit.getSource()); // the retrieved document
list.add(hit.getSource());
}

http://10.0.0.12:9200/_river/dc_user_river/_status?pretty=true

On Monday, March 18, 2013 4:29:56 PM UTC+5:30, srikanth gone wrote:

in elasticsearch.yml

i have given clustername =MyCluster

network:
host: 10.0.0.12

and es.properties

Node test setup

cluster.name=dc-cluster
name=junit.node

Disable network

discovery.zen.ping.multicast.enabled=false
node.local=true
#transport.tcp.port=9300-9400
#discovery.zen.ping.unicast.hosts=localhost

Using less filesystem as possible

index.store.type=memory
index.store.fs.memory.enabled=true
index.gateway.type=none
gateway.type=none

If ES needs to write something, it's here

path.data=/es/twitter

Index are minimalists by default

index.number_of_shards=0
index.number_of_replicas=1

in java..
Node node = NodeBuilder.nodeBuilder().client(true).node();
Client client = node.client();
is there any thing is missing

On Monday, March 18, 2013 3:43:38 PM UTC+5:30, David Pilato wrote:

Are you sure you are joining the cluster in Java?
What do you see in Java logs?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 18 mars 2013 à 11:11, srikanth gone srika...@gmail.com a écrit :

Hi David..

i getting this output: only 5 shards are getting success..

{
"ok" : true,
"_shards" : {
"total" : 10,
"successful" : 5,
"failed" : 0
},
"indices" : {
"dc_user_idx" : {
"index" : {
"primary_size" : "305.8kb",
"primary_size_in_bytes" : 313183,
"size" : "305.8kb",
"size_in_bytes" : 313183
},
"translog" : {
"operations" : 354
},
"docs" : {
"num_docs" : 350,
"max_doc" : 352,
"deleted_docs" : 2
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 12,
"total_time" : "149ms",
"total_time_in_millis" : 149
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
},
"shards" : {
"0" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 0,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "68.6kb",
"size_in_bytes" : 70261
},
"translog" : {
"id" : 1363601429673,
"operations" : 79
},
"docs" : {
"num_docs" : 79,
"max_doc" : 79,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 3,
"total_time" : "26ms",
"total_time_in_millis" : 26
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"1" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 1,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "73.8kb",
"size_in_bytes" : 75662
},
"translog" : {
"id" : 1363601429734,
"operations" : 87
},
"docs" : {
"num_docs" : 87,
"max_doc" : 87,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 3,
"total_time" : "41ms",
"total_time_in_millis" : 41
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"2" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 2,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "63.2kb",
"size_in_bytes" : 64776
},
"translog" : {
"id" : 1363601430455,
"operations" : 73
},
"docs" : {
"num_docs" : 73,
"max_doc" : 73,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "19ms",
"total_time_in_millis" : 19
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"3" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 3,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "46.1kb",
"size_in_bytes" : 47292
},
"translog" : {
"id" : 1363601429801,
"operations" : 53
},
"docs" : {
"num_docs" : 51,
"max_doc" : 52,
"deleted_docs" : 1
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "20ms",
"total_time_in_millis" : 20
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"4" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 4,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "53.8kb",
"size_in_bytes" : 55192
},
"translog" : {
"id" : 1363601429868,
"operations" : 62
},
"docs" : {
"num_docs" : 60,
"max_doc" : 61,
"deleted_docs" : 1
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "43ms",
"total_time_in_millis" : 43
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ]
}
}
}
}

On Monday, March 18, 2013 2:51:59 PM UTC+5:30, David Pilato wrote:

Can you curl http://10.0.0.12:9200/dc_user_idx/_status

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 18 mars 2013 à 08:45, srikanth gone srika...@gmail.com a écrit :

Hi All,

i have used in windows system to search based on text using elastic
search java api..it is working.. when i moved it into linux i am getting
index not found exception..

[dc_user_idx] missing

is there any thing missing.?

this is java code:

Node node = NodeBuilder.nodeBuilder().client(true).node();
Client client = node.client();
SearchResponse response = null;

    response = 

client.prepareSearch().setQuery(QueryBuilders.queryString(""+searchText+"").field("userName").field("firstName").field("displayName").field("lastName").field("email").field("phoneNumber").field("alternativeContact").field("office").field("practice").field("role").field("additionalFields").field("createdBy").field("modifiedBy")).setIndices("dc_user_idx")
.setTypes("DC_USER").execute().actionGet();
SearchHit[] results = response.getHits().getHits();

for (SearchHit hit : results) {
result.put(""+count, hit.getSource()); // the retrieved document
list.add(hit.getSource());
}

http://10.0.0.12:9200/_river/dc_user_river/_status?pretty=true

output:

{
"_index" : "_river",
"_type" : "dc_user_river",
"_id" : "_status",
"_version" : 2,
"exists" : true, "_source" : {"ok":true,"node":{"id":"k54i3bPZRiKvtsrWCqXbPg","name":"Vengeance","transport_address":"inet[/10.0.0.12:9300]"}}
}

http://10.0.0.12:9200/_cluster/health?pretty=true

{
"cluster_name" : "DC_Cluster",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 91,
"active_shards" : 91,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 91
}
can one help me..

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Cluster names are not equals.
Your client probably is not able to join the cluster.

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 18 mars 2013 à 11:59, srikanth gone srikanthg93@gmail.com a écrit :

in elasticsearch.yml

i have given clustername =MyCluster

network:
host: 10.0.0.12

and es.properties

Node test setup

cluster.name=dc-cluster
name=junit.node

Disable network

discovery.zen.ping.multicast.enabled=false
node.local=true
#transport.tcp.port=9300-9400
#discovery.zen.ping.unicast.hosts=localhost

Using less filesystem as possible

index.store.type=memory
index.store.fs.memory.enabled=true
index.gateway.type=none
gateway.type=none

If ES needs to write something, it's here

path.data=/es/twitter

Index are minimalists by default

index.number_of_shards=0
index.number_of_replicas=1

in java..
Node node = NodeBuilder.nodeBuilder().client(true).node();
Client client = node.client();
is there any thing is missing

On Monday, March 18, 2013 3:43:38 PM UTC+5:30, David Pilato wrote:
Are you sure you are joining the cluster in Java?
What do you see in Java logs?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 18 mars 2013 à 11:11, srikanth gone srika...@gmail.com a écrit :

Hi David..

i getting this output: only 5 shards are getting success..

{
"ok" : true,
"_shards" : {
"total" : 10,
"successful" : 5,
"failed" : 0
},
"indices" : {
"dc_user_idx" : {
"index" : {
"primary_size" : "305.8kb",
"primary_size_in_bytes" : 313183,
"size" : "305.8kb",
"size_in_bytes" : 313183
},
"translog" : {
"operations" : 354
},
"docs" : {
"num_docs" : 350,
"max_doc" : 352,
"deleted_docs" : 2
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 12,
"total_time" : "149ms",
"total_time_in_millis" : 149
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
},
"shards" : {
"0" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 0,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "68.6kb",
"size_in_bytes" : 70261
},
"translog" : {
"id" : 1363601429673,
"operations" : 79
},
"docs" : {
"num_docs" : 79,
"max_doc" : 79,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 3,
"total_time" : "26ms",
"total_time_in_millis" : 26
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"1" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 1,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "73.8kb",
"size_in_bytes" : 75662
},
"translog" : {
"id" : 1363601429734,
"operations" : 87
},
"docs" : {
"num_docs" : 87,
"max_doc" : 87,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 3,
"total_time" : "41ms",
"total_time_in_millis" : 41
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"2" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 2,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "63.2kb",
"size_in_bytes" : 64776
},
"translog" : {
"id" : 1363601430455,
"operations" : 73
},
"docs" : {
"num_docs" : 73,
"max_doc" : 73,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "19ms",
"total_time_in_millis" : 19
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"3" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 3,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "46.1kb",
"size_in_bytes" : 47292
},
"translog" : {
"id" : 1363601429801,
"operations" : 53
},
"docs" : {
"num_docs" : 51,
"max_doc" : 52,
"deleted_docs" : 1
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "20ms",
"total_time_in_millis" : 20
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"4" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 4,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "53.8kb",
"size_in_bytes" : 55192
},
"translog" : {
"id" : 1363601429868,
"operations" : 62
},
"docs" : {
"num_docs" : 60,
"max_doc" : 61,
"deleted_docs" : 1
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "43ms",
"total_time_in_millis" : 43
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ]
}
}
}
}

On Monday, March 18, 2013 2:51:59 PM UTC+5:30, David Pilato wrote:
Can you curl http://10.0.0.12:9200/dc_user_idx/_status

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 18 mars 2013 à 08:45, srikanth gone srika...@gmail.com a écrit :

Hi All,

i have used in windows system to search based on text using elastic search java api..it is working.. when i moved it into linux i am getting index not found exception..
[dc_user_idx] missing

is there any thing missing.?

this is java code:

Node node = NodeBuilder.nodeBuilder().client(true).node();
Client client = node.client();
SearchResponse response = null;

    response = client.prepareSearch().setQuery(QueryBuilders.queryString("*"+searchText+"*").field("userName").field("firstName").field("displayName").field("lastName").field("email").field("phoneNumber").field("alternativeContact").field("office").field("practice").field("role").field("additionalFields").field("createdBy").field("modifiedBy")).setIndices("dc_user_idx")
    .setTypes("DC_USER").execute().actionGet();

SearchHit[] results = response.getHits().getHits();

for (SearchHit hit : results) {
result.put(""+count, hit.getSource()); // the retrieved document
list.add(hit.getSource());
}

http://10.0.0.12:9200/_river/dc_user_river/_status?pretty=true

output:

{
"_index" : "_river",
"_type" : "dc_user_river",
"_id" : "_status",
"_version" : 2,
"exists" : true, "_source" : {"ok":true,"node":{"id":"k54i3bPZRiKvtsrWCqXbPg","name":"Vengeance","transport_address":"inet[/10.0.0.12:9300]"}}
}

http://10.0.0.12:9200/_cluster/health?pretty=true

{
"cluster_name" : "DC_Cluster",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 91,
"active_shards" : 91,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 91
}
can one help me..

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

how to give the cluster name from java.. i have not used the es.properties
file

On Monday, March 18, 2013 5:01:00 PM UTC+5:30, David Pilato wrote:

Cluster names are not equals.
Your client probably is not able to join the cluster.

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 18 mars 2013 à 11:59, srikanth gone <srika...@gmail.com <javascript:>>
a écrit :

in elasticsearch.yml

i have given clustername =MyCluster

network:
host: 10.0.0.12

and es.properties

Node test setup

cluster.name=dc-cluster
name=junit.node

Disable network

discovery.zen.ping.multicast.enabled=false
node.local=true
#transport.tcp.port=9300-9400
#discovery.zen.ping.unicast.hosts=localhost

Using less filesystem as possible

index.store.type=memory
index.store.fs.memory.enabled=true
index.gateway.type=none
gateway.type=none

If ES needs to write something, it's here

path.data=/es/twitter

Index are minimalists by default

index.number_of_shards=0
index.number_of_replicas=1

in java..
Node node = NodeBuilder.nodeBuilder().client(true).node();
Client client = node.client();
is there any thing is missing

On Monday, March 18, 2013 3:43:38 PM UTC+5:30, David Pilato wrote:

Are you sure you are joining the cluster in Java?
What do you see in Java logs?

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 18 mars 2013 à 11:11, srikanth gone srika...@gmail.com a écrit :

Hi David..

i getting this output: only 5 shards are getting success..

{
"ok" : true,
"_shards" : {
"total" : 10,
"successful" : 5,
"failed" : 0
},
"indices" : {
"dc_user_idx" : {
"index" : {
"primary_size" : "305.8kb",
"primary_size_in_bytes" : 313183,
"size" : "305.8kb",
"size_in_bytes" : 313183
},
"translog" : {
"operations" : 354
},
"docs" : {
"num_docs" : 350,
"max_doc" : 352,
"deleted_docs" : 2
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 12,
"total_time" : "149ms",
"total_time_in_millis" : 149
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
},
"shards" : {
"0" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 0,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "68.6kb",
"size_in_bytes" : 70261
},
"translog" : {
"id" : 1363601429673,
"operations" : 79
},
"docs" : {
"num_docs" : 79,
"max_doc" : 79,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 3,
"total_time" : "26ms",
"total_time_in_millis" : 26
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"1" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 1,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "73.8kb",
"size_in_bytes" : 75662
},
"translog" : {
"id" : 1363601429734,
"operations" : 87
},
"docs" : {
"num_docs" : 87,
"max_doc" : 87,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 3,
"total_time" : "41ms",
"total_time_in_millis" : 41
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"2" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 2,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "63.2kb",
"size_in_bytes" : 64776
},
"translog" : {
"id" : 1363601430455,
"operations" : 73
},
"docs" : {
"num_docs" : 73,
"max_doc" : 73,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "19ms",
"total_time_in_millis" : 19
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"3" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 3,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "46.1kb",
"size_in_bytes" : 47292
},
"translog" : {
"id" : 1363601429801,
"operations" : 53
},
"docs" : {
"num_docs" : 51,
"max_doc" : 52,
"deleted_docs" : 1
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "20ms",
"total_time_in_millis" : 20
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"4" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 4,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "53.8kb",
"size_in_bytes" : 55192
},
"translog" : {
"id" : 1363601429868,
"operations" : 62
},
"docs" : {
"num_docs" : 60,
"max_doc" : 61,
"deleted_docs" : 1
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "43ms",
"total_time_in_millis" : 43
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ]
}
}
}
}

On Monday, March 18, 2013 2:51:59 PM UTC+5:30, David Pilato wrote:

Can you curl http://10.0.0.12:9200/dc_user_idx/_status

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 18 mars 2013 à 08:45, srikanth gone srika...@gmail.com a écrit :

Hi All,

i have used in windows system to search based on text using elastic
search java api..it is working.. when i moved it into linux i am getting
index not found exception..

[dc_user_idx] missing

is there any thing missing.?

this is java code:

Node node = NodeBuilder.nodeBuilder().client(true).node();
Client client = node.client();
SearchResponse response = null;

    response = 

client.prepareSearch().setQuery(QueryBuilders.queryString(""+searchText+"").field("userName").field("firstName").field("displayName").field("lastName").field("email").field("phoneNumber").field("alternativeContact").field("office").field("practice").field("role").field("additionalFields").field("createdBy").field("modifiedBy")).setIndices("dc_user_idx")
.setTypes("DC_USER").execute().actionGet();
SearchHit[] results = response.getHits().getHits();

for (SearchHit hit : results) {
result.put(""+count, hit.getSource()); // the retrieved document
list.add(hit.getSource());
}

http://10.0.0.12:9200/_river/dc_user_river/_status?pretty=true

output:

{
"_index" : "_river",
"_type" : "dc_user_river",
"_id" : "_status",
"_version" : 2,
"exists" : true, "_source" : {"ok":true,"node":{"id":"k54i3bPZRiKvtsrWCqXbPg","name":"Vengeance","transport_address":"inet[/10.0.0.12:9300]"}}
}

http://10.0.0.12:9200/_cluster/health?pretty=true

{
"cluster_name" : "DC_Cluster",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 91,
"active_shards" : 91,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 91
}
can one help me..

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Read: http://www.elasticsearch.org/guide/reference/java-api/client.html

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 18 mars 2013 à 14:54, srikanth gone srikanthg93@gmail.com a écrit :

how to give the cluster name from java.. i have not used the es.properties file

On Monday, March 18, 2013 5:01:00 PM UTC+5:30, David Pilato wrote:
Cluster names are not equals.
Your client probably is not able to join the cluster.

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 18 mars 2013 à 11:59, srikanth gone srika...@gmail.com a écrit :

in elasticsearch.yml

i have given clustername =MyCluster

network:
host: 10.0.0.12

and es.properties

Node test setup

cluster.name=dc-cluster
name=junit.node

Disable network

discovery.zen.ping.multicast.enabled=false
node.local=true
#transport.tcp.port=9300-9400
#discovery.zen.ping.unicast.hosts=localhost

Using less filesystem as possible

index.store.type=memory
index.store.fs.memory.enabled=true
index.gateway.type=none
gateway.type=none

If ES needs to write something, it's here

path.data=/es/twitter

Index are minimalists by default

index.number_of_shards=0
index.number_of_replicas=1

in java..
Node node = NodeBuilder.nodeBuilder().client(true).node();
Client client = node.client();
is there any thing is missing

On Monday, March 18, 2013 3:43:38 PM UTC+5:30, David Pilato wrote:
Are you sure you are joining the cluster in Java?
What do you see in Java logs?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 18 mars 2013 à 11:11, srikanth gone srika...@gmail.com a écrit :

Hi David..

i getting this output: only 5 shards are getting success..

{
"ok" : true,
"_shards" : {
"total" : 10,
"successful" : 5,
"failed" : 0
},
"indices" : {
"dc_user_idx" : {
"index" : {
"primary_size" : "305.8kb",
"primary_size_in_bytes" : 313183,
"size" : "305.8kb",
"size_in_bytes" : 313183
},
"translog" : {
"operations" : 354
},
"docs" : {
"num_docs" : 350,
"max_doc" : 352,
"deleted_docs" : 2
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 12,
"total_time" : "149ms",
"total_time_in_millis" : 149
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
},
"shards" : {
"0" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 0,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "68.6kb",
"size_in_bytes" : 70261
},
"translog" : {
"id" : 1363601429673,
"operations" : 79
},
"docs" : {
"num_docs" : 79,
"max_doc" : 79,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 3,
"total_time" : "26ms",
"total_time_in_millis" : 26
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"1" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 1,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "73.8kb",
"size_in_bytes" : 75662
},
"translog" : {
"id" : 1363601429734,
"operations" : 87
},
"docs" : {
"num_docs" : 87,
"max_doc" : 87,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 3,
"total_time" : "41ms",
"total_time_in_millis" : 41
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"2" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 2,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "63.2kb",
"size_in_bytes" : 64776
},
"translog" : {
"id" : 1363601430455,
"operations" : 73
},
"docs" : {
"num_docs" : 73,
"max_doc" : 73,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "19ms",
"total_time_in_millis" : 19
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"3" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 3,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "46.1kb",
"size_in_bytes" : 47292
},
"translog" : {
"id" : 1363601429801,
"operations" : 53
},
"docs" : {
"num_docs" : 51,
"max_doc" : 52,
"deleted_docs" : 1
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "20ms",
"total_time_in_millis" : 20
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"4" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 4,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "53.8kb",
"size_in_bytes" : 55192
},
"translog" : {
"id" : 1363601429868,
"operations" : 62
},
"docs" : {
"num_docs" : 60,
"max_doc" : 61,
"deleted_docs" : 1
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "43ms",
"total_time_in_millis" : 43
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ]
}
}
}
}

On Monday, March 18, 2013 2:51:59 PM UTC+5:30, David Pilato wrote:
Can you curl http://10.0.0.12:9200/dc_user_idx/_status

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 18 mars 2013 à 08:45, srikanth gone srika...@gmail.com a écrit :

Hi All,

i have used in windows system to search based on text using elastic search java api..it is working.. when i moved it into linux i am getting index not found exception..
[dc_user_idx] missing

is there any thing missing.?

this is java code:

Node node = NodeBuilder.nodeBuilder().client(true).node();
Client client = node.client();
SearchResponse response = null;

    response = client.prepareSearch().setQuery(QueryBuilders.queryString("*"+searchText+"*").field("userName").field("firstName").field("displayName").field("lastName").field("email").field("phoneNumber").field("alternativeContact").field("office").field("practice").field("role").field("additionalFields").field("createdBy").field("modifiedBy")).setIndices("dc_user_idx")
    .setTypes("DC_USER").execute().actionGet();

SearchHit[] results = response.getHits().getHits();

for (SearchHit hit : results) {
result.put(""+count, hit.getSource()); // the retrieved document
list.add(hit.getSource());
}

http://10.0.0.12:9200/_river/dc_user_river/_status?pretty=true

output:

{
"_index" : "_river",
"_type" : "dc_user_river",
"_id" : "_status",
"_version" : 2,
"exists" : true, "_source" : {"ok":true,"node":{"id":"k54i3bPZRiKvtsrWCqXbPg","name":"Vengeance","transport_address":"inet[/10.0.0.12:9300]"}}
}

http://10.0.0.12:9200/_cluster/health?pretty=true

{
"cluster_name" : "DC_Cluster",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 91,
"active_shards" : 91,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 91
}
can one help me..

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

ok.. thank you david

On Monday, March 18, 2013 7:31:14 PM UTC+5:30, David Pilato wrote:

Read: http://www.elasticsearch.org/guide/reference/java-api/client.html

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 18 mars 2013 à 14:54, srikanth gone <srika...@gmail.com <javascript:>>
a écrit :

how to give the cluster name from java.. i have not used the es.properties
file

On Monday, March 18, 2013 5:01:00 PM UTC+5:30, David Pilato wrote:

Cluster names are not equals.
Your client probably is not able to join the cluster.

David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 18 mars 2013 à 11:59, srikanth gone srika...@gmail.com a écrit :

in elasticsearch.yml

i have given clustername =MyCluster

network:
host: 10.0.0.12

and es.properties

Node test setup

cluster.name=dc-cluster
name=junit.node

Disable network

discovery.zen.ping.multicast.enabled=false
node.local=true
#transport.tcp.port=9300-9400
#discovery.zen.ping.unicast.hosts=localhost

Using less filesystem as possible

index.store.type=memory
index.store.fs.memory.enabled=true
index.gateway.type=none
gateway.type=none

If ES needs to write something, it's here

path.data=/es/twitter

Index are minimalists by default

index.number_of_shards=0
index.number_of_replicas=1

in java..
Node node = NodeBuilder.nodeBuilder().client(true).node();
Client client = node.client();
is there any thing is missing

On Monday, March 18, 2013 3:43:38 PM UTC+5:30, David Pilato wrote:

Are you sure you are joining the cluster in Java?
What do you see in Java logs?

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 18 mars 2013 à 11:11, srikanth gone srika...@gmail.com a écrit :

Hi David..

i getting this output: only 5 shards are getting success..

{
"ok" : true,
"_shards" : {
"total" : 10,
"successful" : 5,
"failed" : 0
},
"indices" : {
"dc_user_idx" : {
"index" : {
"primary_size" : "305.8kb",
"primary_size_in_bytes" : 313183,
"size" : "305.8kb",
"size_in_bytes" : 313183
},
"translog" : {
"operations" : 354
},
"docs" : {
"num_docs" : 350,
"max_doc" : 352,
"deleted_docs" : 2
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 12,
"total_time" : "149ms",
"total_time_in_millis" : 149
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
},
"shards" : {
"0" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 0,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "68.6kb",
"size_in_bytes" : 70261
},
"translog" : {
"id" : 1363601429673,
"operations" : 79
},
"docs" : {
"num_docs" : 79,
"max_doc" : 79,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 3,
"total_time" : "26ms",
"total_time_in_millis" : 26
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"1" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 1,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "73.8kb",
"size_in_bytes" : 75662
},
"translog" : {
"id" : 1363601429734,
"operations" : 87
},
"docs" : {
"num_docs" : 87,
"max_doc" : 87,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 3,
"total_time" : "41ms",
"total_time_in_millis" : 41
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"2" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 2,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "63.2kb",
"size_in_bytes" : 64776
},
"translog" : {
"id" : 1363601430455,
"operations" : 73
},
"docs" : {
"num_docs" : 73,
"max_doc" : 73,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "19ms",
"total_time_in_millis" : 19
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"3" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 3,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "46.1kb",
"size_in_bytes" : 47292
},
"translog" : {
"id" : 1363601429801,
"operations" : 53
},
"docs" : {
"num_docs" : 51,
"max_doc" : 52,
"deleted_docs" : 1
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "20ms",
"total_time_in_millis" : 20
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"4" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 4,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "53.8kb",
"size_in_bytes" : 55192
},
"translog" : {
"id" : 1363601429868,
"operations" : 62
},
"docs" : {
"num_docs" : 60,
"max_doc" : 61,
"deleted_docs" : 1
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "43ms",
"total_time_in_millis" : 43
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ]
}
}
}
}

On Monday, March 18, 2013 2:51:59 PM UTC+5:30, David Pilato wrote:

Can you curl http://10.0.0.12:9200/dc_user_idx/_status

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 18 mars 2013 à 08:45, srikanth gone srika...@gmail.com a écrit :

Hi All,

i have used in windows system to search based on text using elastic
search java api..it is working.. when i moved it into linux i am getting
index not found exception..

[dc_user_idx] missing

is there any thing missing.?

this is java code:

Node node = NodeBuilder.nodeBuilder().client(true).node();
Client client = node.client();
SearchResponse response = null;

    response = 

client.prepareSearch().setQuery(QueryBuilders.queryString(""+searchText+"").field("userName").field("firstName").field("displayName").field("lastName").field("email").field("phoneNumber").field("alternativeContact").field("office").field("practice").field("role").field("additionalFields").field("createdBy").field("modifiedBy")).setIndices("dc_user_idx")
.setTypes("DC_USER").execute().actionGet();
SearchHit[] results = response.getHits().getHits();

for (SearchHit hit : results) {
result.put(""+count, hit.getSource()); // the retrieved document
list.add(hit.getSource());
}

http://10.0.0.12:9200/_river/dc_user_river/_status?pretty=true

output:

{
"_index" : "_river",
"_type" : "dc_user_river",
"_id" : "_status",
"_version" : 2,
"exists" : true, "_source" : {"ok":true,"node":{"id":"k54i3bPZRiKvtsrWCqXbPg","name":"Vengeance","transport_address":"inet[/10.0.0.12:9300]"}}
}

http://10.0.0.12:9200/_cluster/health?pretty=true

{
"cluster_name" : "DC_Cluster",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 91,
"active_shards" : 91,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 91
}
can one help me..

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hi David,

i am still getting index not found exception in my linux remote server

where as in windows its working fine..

my xml
<elasticsearch:node id="esNode" />
<elasticsearch:client node="esNode" id="esClient" />

this is java code

SearchResponse response = null;
response =
client.prepareSearch().setQuery(QueryBuilders.queryString(""+searchText+"").field("userName").field("firstName").field("displayName").field("lastName").field("email").field("phoneNumber").field("alternativeContact").field("office").field("practice").field("role").field("additionalFields").field("createdBy").field("modifiedBy")).setIndices("dc_user_idx")
.setTypes("DC_USER").execute().actionGet();

SearchHit[] results = response.getHits().getHits();
if(results.length != 0){
result = new HashMap<String, Object>();
list = new ArrayList();
}
int count = 0;
for (SearchHit hit : results) {
result.put(""+count, hit.getSource()); // the retrieved document
list.add(hit.getSource());
count++;
}

it is getting exception in linux macine.. index not found exception

status of index is success
http://10.0.0.12:9200/dc_user_idx/_status?pretty

{
"ok" : true,
"_shards" : {
"total" : 10,
"successful" : 5,
"failed" : 0
},
"indices" : {
"dc_user_idx" : {
"index" : {
"primary_size" : "306kb",
"primary_size_in_bytes" : 313373,
"size" : "306kb",
"size_in_bytes" : 313373
},
.....

i have not configured any manual settings
please help me.. is there any thing missing..

On Monday, March 18, 2013 8:37:01 PM UTC+5:30, srikanth gone wrote:

ok.. thank you david

On Monday, March 18, 2013 7:31:14 PM UTC+5:30, David Pilato wrote:

Read: http://www.elasticsearch.org/guide/reference/java-api/client.html

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 18 mars 2013 à 14:54, srikanth gone srika...@gmail.com a écrit :

how to give the cluster name from java.. i have not used the
es.properties file

On Monday, March 18, 2013 5:01:00 PM UTC+5:30, David Pilato wrote:

Cluster names are not equals.
Your client probably is not able to join the cluster.

David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 18 mars 2013 à 11:59, srikanth gone srika...@gmail.com a écrit :

in elasticsearch.yml

i have given clustername =MyCluster

network:
host: 10.0.0.12

and es.properties

Node test setup

cluster.name=dc-cluster
name=junit.node

Disable network

discovery.zen.ping.multicast.enabled=false
node.local=true
#transport.tcp.port=9300-9400
#discovery.zen.ping.unicast.hosts=localhost

Using less filesystem as possible

index.store.type=memory
index.store.fs.memory.enabled=true
index.gateway.type=none
gateway.type=none

If ES needs to write something, it's here

path.data=/es/twitter

Index are minimalists by default

index.number_of_shards=0
index.number_of_replicas=1

in java..
Node node = NodeBuilder.nodeBuilder().client(true).node();
Client client = node.client();
is there any thing is missing

On Monday, March 18, 2013 3:43:38 PM UTC+5:30, David Pilato wrote:

Are you sure you are joining the cluster in Java?
What do you see in Java logs?

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 18 mars 2013 à 11:11, srikanth gone srika...@gmail.com a écrit :

Hi David..

i getting this output: only 5 shards are getting success..

{
"ok" : true,
"_shards" : {
"total" : 10,
"successful" : 5,
"failed" : 0
},
"indices" : {
"dc_user_idx" : {
"index" : {
"primary_size" : "305.8kb",
"primary_size_in_bytes" : 313183,
"size" : "305.8kb",
"size_in_bytes" : 313183
},
"translog" : {
"operations" : 354
},
"docs" : {
"num_docs" : 350,
"max_doc" : 352,
"deleted_docs" : 2
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 12,
"total_time" : "149ms",
"total_time_in_millis" : 149
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
},
"shards" : {
"0" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 0,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "68.6kb",
"size_in_bytes" : 70261
},
"translog" : {
"id" : 1363601429673,
"operations" : 79
},
"docs" : {
"num_docs" : 79,
"max_doc" : 79,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 3,
"total_time" : "26ms",
"total_time_in_millis" : 26
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"1" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 1,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "73.8kb",
"size_in_bytes" : 75662
},
"translog" : {
"id" : 1363601429734,
"operations" : 87
},
"docs" : {
"num_docs" : 87,
"max_doc" : 87,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 3,
"total_time" : "41ms",
"total_time_in_millis" : 41
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"2" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 2,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "63.2kb",
"size_in_bytes" : 64776
},
"translog" : {
"id" : 1363601430455,
"operations" : 73
},
"docs" : {
"num_docs" : 73,
"max_doc" : 73,
"deleted_docs" : 0
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "19ms",
"total_time_in_millis" : 19
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"3" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 3,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "46.1kb",
"size_in_bytes" : 47292
},
"translog" : {
"id" : 1363601429801,
"operations" : 53
},
"docs" : {
"num_docs" : 51,
"max_doc" : 52,
"deleted_docs" : 1
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "20ms",
"total_time_in_millis" : 20
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ],
"4" : [ {
"routing" : {
"state" : "STARTED",
"primary" : true,
"node" : "k54i3bPZRiKvtsrWCqXbPg",
"relocating_node" : null,
"shard" : 4,
"index" : "dc_user_idx"
},
"state" : "STARTED",
"index" : {
"size" : "53.8kb",
"size_in_bytes" : 55192
},
"translog" : {
"id" : 1363601429868,
"operations" : 62
},
"docs" : {
"num_docs" : 60,
"max_doc" : 61,
"deleted_docs" : 1
},
"merges" : {
"current" : 0,
"current_docs" : 0,
"current_size" : "0b",
"current_size_in_bytes" : 0,
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0,
"total_docs" : 0,
"total_size" : "0b",
"total_size_in_bytes" : 0
},
"refresh" : {
"total" : 2,
"total_time" : "43ms",
"total_time_in_millis" : 43
},
"flush" : {
"total" : 0,
"total_time" : "0s",
"total_time_in_millis" : 0
}
} ]
}
}
}
}

On Monday, March 18, 2013 2:51:59 PM UTC+5:30, David Pilato wrote:

Can you curl http://10.0.0.12:9200/dc_user_idx/_status

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 18 mars 2013 à 08:45, srikanth gone srika...@gmail.com a écrit :

Hi All,

i have used in windows system to search based on text using elastic
search java api..it is working.. when i moved it into linux i am getting
index not found exception..

[dc_user_idx] missing

is there any thing missing.?

this is java code:

Node node = NodeBuilder.nodeBuilder().client(true).node();
Client client = node.client();
SearchResponse response = null;

    response = 

client.prepareSearch().setQuery(QueryBuilders.queryString(""+searchText+"").field("userName").field("firstName").field("displayName").field("lastName").field("email").field("phoneNumber").field("alternativeContact").field("office").field("practice").field("role").field("additionalFields").field("createdBy").field("modifiedBy")).setIndices("dc_user_idx")
.setTypes("DC_USER").execute().actionGet();
SearchHit[] results = response.getHits().getHits();

for (SearchHit hit : results) {
result.put(""+count, hit.getSource()); // the retrieved
document
list.add(hit.getSource());
}

http://10.0.0.12:9200/_river/dc_user_river/_status?pretty=true

output:

{
"_index" : "_river",
"_type" : "dc_user_river",
"_id" : "_status",
"_version" : 2,
"exists" : true, "_source" : {"ok":true,"node":{"id":"k54i3bPZRiKvtsrWCqXbPg","name":"Vengeance","transport_address":"inet[/10.0.0.12:9300]"}}
}

http://10.0.0.12:9200/_cluster/health?pretty=true

{
"cluster_name" : "DC_Cluster",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 91,
"active_shards" : 91,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 91
}
can one help me..

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.