How to run elasticsearch-shard in a docker container

Through an unfortunate series of events, data was lost on a node on a 3 node cluster.

All that is left a month old copy of a the data folder.

I am not able to run Elasticsearch-shard --remove-corrupted-data because it needs Elasticsearch to be shut down, and when you do so, the docker container restarts.

I cannot install Elasticsearch on the server. Is there a way to go around that.

Or should I just start the node and try my luck this way? I am worried if I run the node, it will affect other nodes as I am still ingesting data to other nodes and I do not want that to be affected.

EDIT: please note that I still did not start that node since the indecent while the other two nodes are running because I am worried what will happen to the cluster when I run that node with this state. I just copied the backup into the folder and I am waiting.

Is it safe to start that node and then shut it down when I want to use the shard tool?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.