How to set content-header in Kibana?


#1

Hi,

I'm running Elastic 5.4.3

This should be simple, but how do you set the content-header in Kibana or other console like tool?

If I run this PUT command I get an error:

PUT /myindex?pretty

Error: {"error":"Content-Type header [application/x-www-form-urlencoded; charset=UTF-8] is not supported","status":406}


(CJ Cenizal) #2

Hi there, I just want to confirm that you're seeing this error while executing this query in the Dev Tools Console, is that correct?

Thanks,
CJ


#3

Yes...


(CJ Cenizal) #4

I just ran through the steps you've described on Kibana 5.4.3 and I'm unable to reproduce that error. Are you using X-Pack by any chance? Can you double-check and make sure you're using ES 5.4.3, too? And just to confirm, you're by "content-header" I'm assuming you're referring to the content-type header.

To give you some background, the user shouldn't be required to set the content-type header when using Console, which is why this is a bit unusual to me. I wonder if this is related to https://github.com/elastic/kibana/issues/10504. Could you make your request using CURL and let me know if it still returns the same error?

Thanks,
CJ


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.