How to set Elasticsearch 5 Network settings


(Svarup) #1

After changing network.host to my current IP address specified in ifconfig and bootstrap.memory_lock: true elasticsearch does not start

Error:
Dec 17 12:54:45 es-1 systemd[1]: Starting Elasticsearch...
Dec 17 12:54:45 es-1 systemd[1]: Started Elasticsearch.
Dec 17 12:55:59 es-1 systemd[1]: elasticsearch.service: Main process exited, code=exited, status=78/n/a
Dec 17 12:55:59 es-1 systemd[1]: elasticsearch.service: Unit entered failed state.
Dec 17 12:55:59 es-1 systemd[1]: elasticsearch.service: Failed with result 'exit-code'.


(David Pilato) #2

Read the logs.

Share them if you don't understand.

Also read: https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html


(Svarup) #3

after setting LimitMEMLOCK=infinity in /usr/lib/systemd/system/elasticsearch.service problem is solved thanks dadoonet


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.