How to set initial login using OpenID Connect

i want to set SSO using OpenID Connect(google).
So I added the setting to elasticsearch and added the relevant setting to Kibana.

my kibana.yml
xpack.security.authc.providers: [oidc, basic]
xpack.security.authc.oidc.realm: oidc1
server.xsrf.whitelist: [/api/security/oidc/initiate_login]

and keystore add
elasticsearch.username: elastic
elasticsearch.password: mypassword
(The ID:elastic was added with the command 'bin/elasticsearch-setup-passwords interactive'.)

After this setting, the following error occurs when starting the kibana.

log   [01:38:59.926] [warning][licensing][plugins] 
  License information could not be obtained from Elasticsearch for the [data] cluster. 
  [security_exception] unable to authenticate user [elastic] for REST request [/_xpack], 
  with { header={ WWW-Authenticate={ 0="Bearer realm=\"security\"" & 1="Basic realm=\"security\" charset=\"UTF-8\"" } } } :: 
  {"path":"/_xpack","statusCode":401,"response":"{\"error\":{\"root_cause\": [{\"type\":\"security_exception\",
  \"reason\":\"unable to authenticate user [elastic] for REST request [/_xpack]\",
  \"header\":{\"WWW-Authenticate\":[\"Bearer realm=\\\"security\\\"\",
  \"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"]}}],
  \"type\":\"security_exception\",\"reason\":\"unable to authenticate user [elastic] for REST request [/_xpack]\",
  \"header\":{\"WWW-Authenticate\":[\"Bearer realm=\\\"security\\\"\",\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"]}},
  \"status\":401}","wwwAuthenticateDirective":"Bearer realm=\"security\", Basic realm=\"security\" charset=\"UTF-8\""}

what i have to add setting?

A number of things can be happening to get to that authentication exception you see thrown by ES.

Thanks
Rashmi