How to set routing allocation on the filebeat template

I use ECK and i have filebeat setup. I have 3 nodeset Elasticsearch cluster, one which is named "monitoring" i have defined the node attri according to the following docs (Index-level shard allocation filtering | Elasticsearch Guide [8.2] | Elastic.

My goal is to allocate the default filebeat template to a specific nodeset.

...
nodeSets:
 - name: monitoring 
    count: 1
    config:
      node.store.allow_mmap: false
      node.attr.type: monitoring
...

My filebeat.yml config looks like the following: Configure Elasticsearch index template loading | Filebeat Reference [8.2] | Elastic

apiVersion: beat.k8s.elastic.co/v1beta1
kind: Beat
metadata:
  name: filebeat
  namespace: elastic-system
spec:
  type: filebeat
  version: 8.2.0
  elasticsearchRef:
    name: elasticsearch-prod
  kibanaRef:
    name: kibana-prod
  config:
    filebeat:
      setup:
        template:
          settings:
            "index.routing.allocation.require.type": "monitoring"
...

However i can see the routing allocation has not been set.

GET filebeat-*/_settings

{
  ".ds-filebeat-8.2.0-2022.05.12-000001" : {
    "settings" : {
        "routing" : {
          "allocation" : {
            "include" : {
              "_tier_preference" : "data_hot"
            }
          }
        },
        "number_of_shards" : "1",
        "max_docvalue_fields_search" : "200"
      }
    }
  }
}

Any idea what i am doing wrong?