How to split an Index, number_of_routing_shards issue

I want to split my index with 5 shards into 10 or 30 shards. At first I tried it with the _splitAPI but i get the following result
the number of routing shards [5] must be a multiple of the target shards [10]
I tried changing the settings of the routing shards and I got back an "acknowledged":

But when I tried to split the the index again I get the same error and it says that my number of routing shards is 5.
When I use GET index/_settings it displays number_of_routing_shards "30"

How do I fix this?

I assume you are using Elasticsearch 6.x, and in that case the docs state that the index need to be created with number_of_routing_shards set. You can therefore not set this parameter for existing indices, so will need to reindex to increase the primary shard count. In Elasticsearch 7.x I believe this parameter is set by default when indices are created.

I use Elastic 7.7. So I would need to reindex the whole thing?

Not if the index was created in Elasticsearch 7 and not migrated fro version 6.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.