How to use es analyzer for compound words?

here is an example for an index with some documents containing dutch
compound words.

"plaatstaal" is a dutch compound word. So after the custom analyzer "dutch"
has been assigned to the field test I expected a search for "plaat" would
return at least one hit.
That's what i get:

search for plaat
{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 1,
"successful" : 1,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

Any idea why this is not working?
Thanks for your help

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5f61d2c7-0385-4a9c-adb0-600c2f442e58%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

For decompounding, you need a more sophisticated algorithm, like in my
plugin

which provides decompounding for german words.

Jörg

On Wed, Oct 22, 2014 at 4:09 PM, sebninse sebninse@gmail.com wrote:

here is an example for an index with some documents containing dutch
compound words.
https://gist.github.com/herrvonb/0a247aa7dfd0d155b418

"plaatstaal" is a dutch compound word. So after the custom analyzer
"dutch" has been assigned to the field test I expected a search for "plaat"
would return at least one hit.
That's what i get:

search for plaat
{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 1,
"successful" : 1,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

Any idea why this is not working?
Thanks for your help

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/5f61d2c7-0385-4a9c-adb0-600c2f442e58%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/5f61d2c7-0385-4a9c-adb0-600c2f442e58%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoGVKKrxKoZ6JKaACj-dHVuXF9m-3H8hJkAwD0ZaP9dubA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.