Update analyzer (stopwords)


(Maikel Janssen) #1

Hello,

Just starting using elasticsearch (this is the cluster code 5b399c ) and the basics are setup and working well. Now i am trying to update the elasticsearch analyzer based on the article here; https://www.elastic.co/guide/en/elasticsearch/reference/current/analysis-lang-analyzer.html#dutch-analyzer

I am using elastic cloud (5.2 version).

I copy and pasted the configuration listed there and tried the one with the keywords filled, keywords empty and keywords removed.

But in all 3 cases the response i get is the following; keyword filter requires either keywords or keywords_path to be configured :frowning:

Any idea what i am doing wrong? Caught up on the documentation and everything that was there does not seem to help. Could really use some help.

Checked this article too Set Elastic to search in other language but no reply there either. And listed the problem here too just now, to see if someone can help me with it Language analyzer en fran├žais

This is an example of a try (the one without the keywords set) i tried to leave as much as possible intact. I do not need the override as well, but thought it would do no harm.

curl -XPUT  'clustername/indexname/_settings' -d '{
  "settings": {
    "analysis": {
      "filter": {
        "dutch_stop": {
          "type":       "stop",
          "stopwords":  "_dutch_" 
        },
        "dutch_stemmer": {
          "type":       "stemmer",
          "language":   "dutch"
        },
        "dutch_override": {
          "type":       "stemmer_override",
          "rules": [
            "fiets=>fiets",
            "bromfiets=>bromfiets",
            "ei=>eier",
            "kind=>kinder"
          ]
        }
      },
      "analyzer": {
        "dutch": {
          "tokenizer":  "standard",
          "filter": [
            "lowercase",
            "dutch_stop",
            "dutch_override",
            "dutch_stemmer"
          ]
        }
      }
    }
  }
}'

Also tried a more clean version where i left out the dutch_keywords and the dutch_override;

{
  "settings": {
    "analysis": {
      "filter": {
        "dutch_stop": {
          "type":       "stop",
          "stopwords":  "_dutch_"
        },
        "dutch_stemmer": {
          "type":       "stemmer",
          "language":   "dutch"
        }                                 
      },           
      "analyzer": {
        "dutch": {                 
          "tokenizer":  "standard",
          "filter": [   
            "lowercase", 
            "dutch_stop",  
            "dutch_stemmer"
          ]
        }
      }
    }
  }
}

This one will not work either.


Set Elastic to search in other language
Language analyzer en fran├žais
(system) #2

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.