Set Elastic to search in other language

Hello there!
I'm a new user of Elasticsearch and I'm trying to set my index to work with other language (with czech language). I have read some tutorials about analyzers and tryed to use the example code.
The problem is, when I try to run the code (in Kibana dev tools), I get an error:

  "error": {
    "root_cause": [
        "type": "illegal_argument_exception",
        "reason": "keyword filter requires either `keywords` or `keywords_path` to be configured"
    "type": "illegal_argument_exception",
    "reason": "keyword filter requires either `keywords` or `keywords_path` to be configured"
  "status": 400

The code I try to run looks like this:

PUT /university/_settings
  "settings": {
    "analysis": {
      "filter": {
        "czech_stop": {
          "type":       "stop",
          "stopwords":  "_czech_" 
        "czech_stemmer": {
          "type":       "stemmer",
          "language":   "czech"
      "analyzer": {
        "czech": {
          "tokenizer":  "standard",
          "filter": [
        } } } } }

I have deleted the "keywords" part mentioned in the "tutorial" but I'm still getting the error. What am I doing wrong? Can you give me any advice please?
And the second thing I want to ask: is there anything more I have to do, if I want Elasticsearch to work with czech language, except this setting? I need it to work with search and fulltext search in czech language.

Many thanks for any reply and advice!

1 Like

Experiencing the same problem, but then with the dutch settings. Update analyzer (stopwords)

Even found this issue, but it does not seem to conclude in a solution

Gotten any further with this?


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.