How to use ingest attachment processor in elastic cloud

how to use ingest attachment processor in elastic cloud
Elastic search is not in local i am using free trial cloud

when i run this in dev tools

PUT _ingest/pipeline/attachment
  "description" : "Extract attachment information",
  "processors" : [
      "attachment": {
        "name" : "body",
        "indexed_chars" : -1

it gives this error

  "error" : {
    "root_cause" : [
        "type" : "parse_exception",
        "reason" : "No processor type exists with name [attachment]",
        "processor_type" : "attachment"
    "type" : "parse_exception",
    "reason" : "No processor type exists with name [attachment]",
    "processor_type" : "attachment"
  "status" : 400

You did not install the attachment plugin. You need to edit your Cloud deployment settings to add it

i have added it in edit, but not work yet same error

Could you run:

GET /_cat/plugins?v

i forgot to save it, I only checked and left the page

this is plugin

name                  component         version
instance-0000000000   ingest-attachment 7.14.1
instance-0000000000   repository-gcs    7.14.1
instance-0000000000   repository-s3     7.14.1
instance-0000000001   ingest-attachment 7.14.1
instance-0000000001   repository-gcs    7.14.1
instance-0000000001   repository-s3     7.14.1
tiebreaker-0000000002 ingest-attachment 7.14.1
tiebreaker-0000000002 repository-gcs    7.14.1
tiebreaker-0000000002 repository-s3     7.14.1


So it works now, right?

yes it works, this problem solved

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.