How to use Kibana to display the localtime for dashlets?

We are inserting each record in elasticSearch index(test_elastalert1) with having two time fields(from python code) as below

"time" : datetime.utcnow().isoformat()+'Z',

"local_time" :

Below are the corresponding values for record in index,test_elastalert1:



We have inserted multiple records in index and able to see the total count when I run match_all DSL query. But the count is not getting displayed correctly when I search last one hr. whereas if I select last 12hrs the data is displaying with local time stamp. I tried with local_time and time in “date Histogram” .

Kibana uses the Browser timezone by default when displaying documents and working with time. You can set it in the Advanced settings and then you can check again your queries to see if it works as you want it then.

Elasticsearch and Kibana assumes/requires all timestamps stored to be in UTC timezone. If you are storing fields in a different timezone you are therefore see data offset.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.