How to use stopword elasticsearch

i have a Elasticsearch 1.5 running on my server,

specifically i want/create three field with is 1.name field 2.description
3.nickname

i want setup stopword for decription and nickname field ,when i insert the
data on the Elasticsearch then stop word automatically remove unwanted
stopword. im trying so many time but not working.

curl -X POST http://127.0.0.1:9200/tryoindex/ -d'
{
"settings": {
"analysis": {
"filter": {
"custom_english_stemmer": {
"type": "stemmer",
"name": "english"
},
"snowball": {
"type" : "snowball",
"language" : "English"
}
},
"analyzer": {
"custom_lowercase_stemmed": {
"tokenizer": "standard",
"filter": [
"lowercase",
"custom_english_stemmer",
"snowball"
]
}
}
}
},
"mappings": {
"test": {
"_all" : {"enabled" : true},
"properties": {
"text": {
"type": "string",
"analyzer": "custom_lowercase_stemmed"
}
}
}
}
}'
curl -X POST "http://localhost:9200/tryoindex/nama/1" -d '{
"text" : "Tryolabs running monkeys KANGAROOS and jumping elephants jum is
your"
}'
curl "http://localhost:9200/tryoindex/nama/_search?pretty=1" -d '{
"query": {
"query_string": {
"query": "Tryolabs running monkeys KANGAROOS and jumping elephants jum is
your",
"fields": ["text"]
}
}
}'

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5519a372-4ca5-4149-8ba2-acb6f18153c0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Take a look at
http://www.elastic.co/guide/en/elasticsearch/reference/current/analysis-stop-analyzer.html,
it looks like you need to define the words you want to stop.

On 13 April 2015 at 14:49, Mohd Syafiq syafiqapit2002@gmail.com wrote:

i have a Elasticsearch 1.5 running on my server,

specifically i want/create three field with is 1.name field 2.description
3.nickname

i want setup stopword for decription and nickname field ,when i insert the
data on the Elasticsearch then stop word automatically remove unwanted
stopword. im trying so many time but not working.

curl -X POST http://127.0.0.1:9200/tryoindex/ -d'
{
"settings": {
"analysis": {
"filter": {
"custom_english_stemmer": {
"type": "stemmer",
"name": "english"
},
"snowball": {
"type" : "snowball",
"language" : "English"
}
},
"analyzer": {
"custom_lowercase_stemmed": {
"tokenizer": "standard",
"filter": [
"lowercase",
"custom_english_stemmer",
"snowball"
]
}
}
}
},
"mappings": {
"test": {
"_all" : {"enabled" : true},
"properties": {
"text": {
"type": "string",
"analyzer": "custom_lowercase_stemmed"
}
}
}
}
}'
curl -X POST "http://localhost:9200/tryoindex/nama/1" -d '{
"text" : "Tryolabs running monkeys KANGAROOS and jumping elephants jum is
your"
}'
curl "http://localhost:9200/tryoindex/nama/_search?pretty=1" -d '{
"query": {
"query_string": {
"query": "Tryolabs running monkeys KANGAROOS and jumping elephants jum is
your",
"fields": ["text"]
}
}
}'

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/5519a372-4ca5-4149-8ba2-acb6f18153c0%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/5519a372-4ca5-4149-8ba2-acb6f18153c0%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X9q%2BsqPK2_riKUpO8zEtaaf3w2cCdA60py8XZ1CkiVn1g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

i already do some codes and try run it's but when i view using head plugin
, the "is" "the" word in index still appear

On Mon, Apr 13, 2015 at 1:33 PM, Mark Walkom markwalkom@gmail.com wrote:

Take a look at
http://www.elastic.co/guide/en/elasticsearch/reference/current/analysis-stop-analyzer.html,
it looks like you need to define the words you want to stop.

On 13 April 2015 at 14:49, Mohd Syafiq syafiqapit2002@gmail.com wrote:

i have a Elasticsearch 1.5 running on my server,

specifically i want/create three field with is 1.name field
2.description 3.nickname

i want setup stopword for decription and nickname field ,when i insert
the data on the Elasticsearch then stop word automatically remove unwanted
stopword. im trying so many time but not working.

curl -X POST http://127.0.0.1:9200/tryoindex/ -d'
{
"settings": {
"analysis": {
"filter": {
"custom_english_stemmer": {
"type": "stemmer",
"name": "english"
},
"snowball": {
"type" : "snowball",
"language" : "English"
}
},
"analyzer": {
"custom_lowercase_stemmed": {
"tokenizer": "standard",
"filter": [
"lowercase",
"custom_english_stemmer",
"snowball"
]
}
}
}
},
"mappings": {
"test": {
"_all" : {"enabled" : true},
"properties": {
"text": {
"type": "string",
"analyzer": "custom_lowercase_stemmed"
}
}
}
}
}'
curl -X POST "http://localhost:9200/tryoindex/nama/1" -d '{
"text" : "Tryolabs running monkeys KANGAROOS and jumping elephants jum is
your"
}'
curl "http://localhost:9200/tryoindex/nama/_search?pretty=1" -d '{
"query": {
"query_string": {
"query": "Tryolabs running monkeys KANGAROOS and jumping elephants jum is
your",
"fields": ["text"]
}
}
}'

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/5519a372-4ca5-4149-8ba2-acb6f18153c0%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/5519a372-4ca5-4149-8ba2-acb6f18153c0%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/FLMjlTsa-Q0/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEYi1X9q%2BsqPK2_riKUpO8zEtaaf3w2cCdA60py8XZ1CkiVn1g%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAEYi1X9q%2BsqPK2_riKUpO8zEtaaf3w2cCdA60py8XZ1CkiVn1g%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAK9TPB4SXo5Li4GQPHA2QXEKaR0_ydUwb3%3DNj8U-hJpO8xfKnA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.