I am trying to deploy kibana using helm on my gke cluster

Hi
I am trying to deploy kibana using helm

How do we add basepath to something else other than / which is default

I tried this

kibanaConfig: {}
kibana.yml: |
server.basepath: "/kibana"

however whenever i try to deploy it
helm install -f custom_kibana.yaml --name kibana1 elastic/kibana --version 7.1.1
Error: failed to parse custom_kibana.yaml: error converting YAML to JSON: yaml: line 45: did not find expected key
[arunsrinivasan@kube-in-cluster-3 ~]$

I get the error above

Hey @asrinivasan
I don't know much about helm charts, but the errors seems related to a wrong key int he custom_kibana.yml file. Can you share it or at least send what is written in line 45?

If that line is the line with the base path, can you check if that is written as: server.basePath with the uppercase P ?

The issue is that you are setting kibanaConfig to a blank hash so the section below is being ignored. Can you try it again with this:

Note: I only removed the {}

kibanaConfig:
  kibana.yml: |
    server.basepath: "/kibana"

Thx Michael yes that worked, i had realized it after posting, thx for the help

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.