I am unable to run Kibana 8.6.1 from browser

Hi Team,

I am unable to connect to kibana from browser. I have installed Kibana, 8.6.1 . I am getting
HTTP/1.1 302 Found when I do a curl on the URL from the VM , but unable to get response when I try to access from browser. Request for guidance to solve this one .

@vansh I had seen in the discussion board that you too faced a similar challenge . Can you please guide on how you resolved it . I tried incognito too .

Welcome to our community! :smiley:

Can you share the full curl and response please?

Thank you Mark for the welcome :slight_smile:

If I curl the from the VM where the service is running, I am getting the below message:

curl -v "https://dnsname/kibana/"

HTTP/1.1 302 Found
Location: /login?next=%2F
x-content-type-options: nosniff
referrer-policy: no-referrer-when-downgrade
content-security-policy: script-src 'self' 'unsafe-eval'; worker-src blob: 'self'; style-src 'unsafe-inline' 'self'
Kbn-name: nameOfKibana
Kbn-license-sig: some serial number
X-envoy-upsteam-service-time: 9
Server: istio-envoy

Hey Mark , the above is the response I get on doing curl. Actually I am typing each line same as what output I saw when I ran the command on the VM

Are you using our ECK operator?

Yes . Using ECK operator. Operator version 2.6

Are there any changes required in the operator yaml ? Also, I am getting error connecting to fleet registry error in Kibana Logs. I am okay with even disabling my fleet. Is this causing an issue in opening kibana through browser ? Please suggest. Thank you in advance.

Please advise


I think you are using Istio? I'm definitely not an Isitio expert, but would it be possible to do a test bypassing the Envoy proxy? It would help to understand if you are facing a configuration issue with Envoy.
We have also an Istio recipe, it's not up to date, but I noticed there are some annotations to let the traffic flow between components, maybe that could help.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.