I can't reopen a closed index

Hi all,
I'm pretty new to ES but have played around with ELK stack a bit and I'm more familiar now to run some API queries and modifying configs.
I have closed an index called accelerate which is the main source of our dashboards in Kibana by mistake and when attempting to re-open it, I get below error.
I'm using below API call and receive the error pasted below:

POST /accelerate/_open

  "error" : {
    "root_cause" : [
        "type" : "exception",
        "reason" : "Failed to verify index [accelerate/6TtZD3oTTVaGiDyXDnL9Kg]"
    "type" : "exception",
    "reason" : "Failed to verify index [accelerate/6TtZD3oTTVaGiDyXDnL9Kg]",
    "caused_by" : {
      "type" : "illegal_argument_exception",
      "reason" : "Setting index.mapper.dynamic was removed after version 6.0.0"
  "status" : 500

I have tried to disable this setting (index.mapper.dynamic) in my index configs but it throws the same error each time and I'm stuck with a closed index which is very important for us.

What do you suggest?

Hey @Hatef and welcome to the community!

are there any templates that reference that setting? does this post help you at all?

Hello @Hatef,

Welcome to the community!

Did you upgrade in the meantime? Which version of Elastic are you using?

Perhaps this is mentioned in an index template? You probably have: "dynamic":"true" in your index mapping.

Have you tried deleting and creating a new template or updating this template?

Hi @eMitch
This index is not using index templates but the settings of this index does come with index.mapper.dynamic set to true and I can't disable or remove it by any means

Below is the output of _settings endpoint:
Screenshot 2023-06-13 at 20.55.37

Hi @Priscilla_Parodi,
No upgrade is done. The version of Elastic is v 7.9.1
This index is not using any index templates.

Looks like this is an active bug.

See: Removed setting `index.mapper.dynamic` can be set on v7+ indices · Issue #96075 · elastic/elasticsearch · GitHub

Commenting on this ticket would increase visibility and allow you to keep track.


Please note that version is EOL and no longer supported, you should be looking to upgrade as a matter of urgency as the bug that is linked above will not be back ported to anything other than a 7.17 version.


Since the index is closed right now and it is crucial for us to get it back, is there any solution you can suggest despite removing and recreating the index? I need the data in that index and don't want to remove it.

Hello @Hatef,

Considering the context, I believe the best option would be for you to create a snapshot (set "expand_wildcards" to "all"; in 7.x, the value defaults to "open, hidden" indices). Then, proceed with the upgrade and restore the snapshot.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.