I can't see the link that takes me to the URL of the search result in the custom API source

I have registered an online document in my custom API source.

I assume that if I register the URL of the document at the time of registration, I can access the URL from the result of the searched document, but the link icon does not appear when I mouse over the document I have registered.
Is there any setting I need to do?

Hi @its-ogawa . If your schema fields in the custom source have non-standard names (for example, the field containing the URL isn't named url etc), you might want to tweak Display Settings. Hope that helps!

Thank you for your answer.

Hmmm.
I have registered the value as url properly.
Even with the standard settings, the URL is displayed in the search results in the place corresponding to url.
Copy and paste the displayed URL into your browser to access the expected page.

I thought I could access that URL when I selected the search result, is that not correct?

Ah. I see.
I'm sorry. I knew you were right.

You need to include the url in the Visible Fields in the Display Settings.
That way, you can access the URL link just by selecting the search result.
Excellent.

If possible, this feature would be nice to have as a standard feature after registering the url.