I can't start Kibana on Ubuntu 16.04

I installed the ELK package. Elasticsearch, kibana and logstash. Elasticsear seems to be working fine but i can't seem to be able to start kibana.
Here are the results of sudo service kibana status

kibana.service - Kibana
Loaded: loaded (/etc/systemd/system/kibana.service; enabled; vendor preset: e
Active: failed (Result: start-limit-hit) since خ 2020-03-05 00:09:07 CET; 4mi
Process: 2550 ExecStart=/usr/share/kibana/bin/kibana -c /etc/kibana/kibana.yml
Main PID: 2550 (code=exited, status=1/FAILURE)

مار 05 00:09:06 bruce-VirtualBox systemd[1]: kibana.service: Main process exited
مار 05 00:09:06 bruce-VirtualBox systemd[1]: kibana.service: Unit entered failed
مار 05 00:09:06 bruce-VirtualBox systemd[1]: kibana.service: Failed with result
مار 05 00:09:07 bruce-VirtualBox systemd[1]: kibana.service: Service hold-off ti
مار 05 00:09:07 bruce-VirtualBox systemd[1]: Stopped Kibana.
مار 05 00:09:07 bruce-VirtualBox systemd[1]: kibana.service: Start request repea
مار 05 00:09:07 bruce-VirtualBox systemd[1]: Failed to start Kibana.
مار 05 00:09:07 bruce-VirtualBox systemd[1]: kibana.service: Unit entered failed
مار 05 00:09:07 bruce-VirtualBox systemd[1]: kibana.service: Failed with result

and here are the contents of the kibana.yml file

Kibana is served by a back end server. This setting specifies the port to use.
#server.port: 5601

Specifies the address to which the Kibana server will bind. IP addresses and $

The default is 'localhost', which usually means remote machines will not be a$

To allow connections from remote users, set this parameter to a non-loopback $

#server.host: "localhost"

Enables you to specify a path to mount Kibana at if you are running behind a $

Use the server.rewriteBasePath setting to tell Kibana if it should remove t$

from requests it receives, and to prevent a deprecation warning at startup.

This setting cannot end in a slash.

#server.basePath: ""

Specifies whether Kibana should rewrite requests that are prefixed with

server.basePath or require that they are rewritten by your reverse proxy.

This setting was effectively always false before Kibana 6.3 and will

default to true starting in Kibana 7.0.

#server.rewriteBasePath: false

from requests it receives, and to prevent a deprecation warning at startup.

This setting cannot end in a slash.

#server.basePath: ""

Specifies whether Kibana should rewrite requests that are prefixed with

server.basePath or require that they are rewritten by your reverse proxy.

This setting was effectively always false before Kibana 6.3 and will

default to true starting in Kibana 7.0.

#server.rewriteBasePath: false

The maximum payload size in bytes for incoming server requests.

#server.maxPayloadBytes: 1048576

The Kibana server's name. This is used for display purposes.

server.name: "localhost"

The URLs of the Elasticsearch instances to use for all your queries.

#elasticsearch.hosts: ["http://localhost:9200"]
elasticsearch.url:"http://localhost:9200"

Please format your code/logs/config using the </> button in the text editor, or markdown style back ticks. It helps to make things easy to read which helps us help you :slight_smile:

What do the actual Kibana logs show?

I didn't have any logs , i purged both kibana and elasticsearch to fix it.

It's going to be super hard to troubleshoot without logs.

I found a solution for this, which is deleting this version and installing the newest. I am however facing another problem which i posted the logs for.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.