"[ignore_throttled] parameter is deprecated because frozen indices have been deprecated

Continuing the discussion from Ignore_throttled parameter is deprecated:


I upgrade my ES and Kibana version to 7.16.3 from 7.15.0 and post upgrading, this warning is showing on my kibana continuously. Can you let me know how to get rid of these warnings?

Welcome to our community! :smiley:

See Unfreeze index API | Elasticsearch Guide [8.1] | Elastic. Basically in 8.X you can't freeze an index, so you need to move off this :slight_smile:

Are you saying that we cannot use Elasticsearch 7.15.x, 7.16.x, 7.17.x if we do not want to see this deprecation warning (even if we're not using frozen indices)?

Coming from Default IndicesOptions in SearchRequest and disable specific deprecation warnings this feels weird. :frowning_face:

Uhh, not sure how you got that sorry?
You won't get a deprecation logged for something you aren't using.

Unfortunately that's exactly what's happening when using ES 7.16.0 or higher and the Java High Level REST Client (even in the same version).

Sorry for hijacking this thread, I'll stop posting in this topic now.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.