Hi, I have problem with elastic error illegal_argument_exception because I changed field from text to number. However only new indexes have number field, old still have text field - I guess.

"type": "illegal_argument_exception", "reason": "Text fields are not optimised for operations that require per-document field data like aggregations and sorting, so these operations are disabled by default. Please use a keyword field instead. Alternatively, set fielddata=true on [XXX] in order to load field data by uninverting the inverted index. Note that this can use significant memory."

How can I fix it? Do I need reindex all? If yes, how? I have few daily indexes.


A reindex for your older data is the best approach.

Reindex API | Elasticsearch Guide [7.15] | Elastic is the best place to start :slight_smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.