Impossible d'installer elasticsearch-head


#1

Bonjour,

Lorsque j'essaye d'exécuter la commande: ./bin/plugin -install mobz/elasticsearch-head, j'ai l'erreur suivante:

Erreur : impossible de trouver ou charger la classe principale org.elasticsearch.plugins.PluginManagerCliParser

Pourriez-vous me dire d'où vient cette erreur?

Merci!


Can not install ElasticSearch-Head
(David Pilato) #2

Je ne sais pas quelle version tu utilises mais si c'est une version 2.0 ou sup, tu dois respecter ceci: https://www.elastic.co/guide/en/elasticsearch/plugins/current/installation.html

bin/plugin install xxxx

Je ne sais pas si le plugin HEAD a été mis à jour néanmoins.


#3

Merci pour le lien, ça résout le problème. Néanmoins, j'ai dû rajouter l'extension ".bat" à plugin pour que ça marche.


(system) #4