Include a plugin using Tomcat


(Bibin Abraham) #1

Hi,

I have wrapped Elasticsearch in Tomcat and am using
elasticsearch-transport-wares for this purpose. How can I add a plugin to
this instance as Im planning to use jdbc river plugin?

Thanks & Regards

bin :slight_smile:

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Igor Motov) #2

Just copy the plugin to any directory that is accessible by the tomcat
process and specify this directory in the path.plugins setting of your
elasticsearch node.

On Wednesday, September 11, 2013 8:27:42 AM UTC-4, bin wrote:

Hi,

I have wrapped Elasticsearch in Tomcat and am using
elasticsearch-transport-wares for this purpose. How can I add a plugin to
this instance as Im planning to use jdbc river plugin?

Thanks & Regards

bin :slight_smile:

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #3

You can also just add your plugin in the classloader.
For example, add it as a maven dependency in your project and that's all.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 11 sept. 2013 à 15:00, Igor Motov imotov@gmail.com a écrit :

Just copy the plugin to any directory that is accessible by the tomcat process and specify this directory in the path.plugins setting of your elasticsearch node.

On Wednesday, September 11, 2013 8:27:42 AM UTC-4, bin wrote:
Hi,

I have wrapped Elasticsearch in Tomcat and am using elasticsearch-transport-wares for this purpose. How can I add a plugin to this instance as Im planning to use jdbc river plugin?

Thanks & Regards

bin :slight_smile:

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Bibin Abraham) #4

Hi Igor,David,

Thanks for your help.

I added the river-jdbc jar in WEB-INF/lib. Then I tried the following:

curl -XPUT "http://localhost:9200/_river/my_jdbc_river/_meta" -d '{...}'

output:
{
"error": "IndexMissingException[[_river] missing]",
"status": 404
}

Then I created a folder-plugins/river-jdbc and added its jars over there. I
configured the elasticsearch.yml to point to the dir. Still I got the same
exception.
Then I made the plugin mandatory and I got
"org.elasticsearch.ElasticSearchException: Missing mandatory plugins
[river-jdbc]
org.elasticsearch.plugins.PluginsService.<init>(PluginsService.java:99)
"

BTW, I gave the absolute path for the above.

Thanks and Regards

bin :slight_smile:

On Wednesday, September 11, 2013 6:47:48 PM UTC+5:30, David Pilato wrote:

You can also just add your plugin in the classloader.
For example, add it as a maven dependency in your project and that's all.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 11 sept. 2013 à 15:00, Igor Motov <imo...@gmail.com <javascript:>> a
écrit :

Just copy the plugin to any directory that is accessible by the tomcat
process and specify this directory in the path.plugins setting of your
elasticsearch node.

On Wednesday, September 11, 2013 8:27:42 AM UTC-4, bin wrote:

Hi,

I have wrapped Elasticsearch in Tomcat and am using
elasticsearch-transport-wares for this purpose. How can I add a plugin to
this instance as Im planning to use jdbc river plugin?

Thanks & Regards

bin :slight_smile:

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #5

How do you start es from your webapp?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 11 sept. 2013 à 20:16, bin bibin.abraham.dev@gmail.com a écrit :

Hi Igor,David,

Thanks for your help.

I added the river-jdbc jar in WEB-INF/lib. Then I tried the following:

curl -XPUT "http://localhost:9200/_river/my_jdbc_river/_meta" -d '{...}'

output:
{
"error": "IndexMissingException[[_river] missing]",
"status": 404
}

Then I created a folder-plugins/river-jdbc and added its jars over there. I configured the elasticsearch.yml to point to the dir. Still I got the same exception.
Then I made the plugin mandatory and I got
"org.elasticsearch.ElasticSearchException: Missing mandatory plugins [river-jdbc]
org.elasticsearch.plugins.PluginsService.<init>(PluginsService.java:99)
"

BTW, I gave the absolute path for the above.

Thanks and Regards

bin :slight_smile:

On Wednesday, September 11, 2013 6:47:48 PM UTC+5:30, David Pilato wrote:

You can also just add your plugin in the classloader.
For example, add it as a maven dependency in your project and that's all.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 11 sept. 2013 à 15:00, Igor Motov imo...@gmail.com a écrit :

Just copy the plugin to any directory that is accessible by the tomcat process and specify this directory in the path.plugins setting of your elasticsearch node.

On Wednesday, September 11, 2013 8:27:42 AM UTC-4, bin wrote:

Hi,

I have wrapped Elasticsearch in Tomcat and am using elasticsearch-transport-wares for this purpose. How can I add a plugin to this instance as Im planning to use jdbc river plugin?

Thanks & Regards

bin :slight_smile:

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Bibin Abraham) #6

I am using elasticsearch-transport-wares servlets

Thanks & Regards

bin :slight_smile:

On Thursday, 12 September 2013 01:02:24 UTC+5:30, David Pilato wrote:

How do you start es from your webapp?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 11 sept. 2013 à 20:16, bin <bibin.ab...@gmail.com <javascript:>> a
écrit :

Hi Igor,David,

Thanks for your help.

I added the river-jdbc jar in WEB-INF/lib. Then I tried the following:

curl -XPUT "http://localhost:9200/_river/my_jdbc_river/_meta" -d '{...}'

output:
{
"error": "IndexMissingException[[_river] missing]",
"status": 404
}

Then I created a folder-plugins/river-jdbc and added its jars over there.
I configured the elasticsearch.yml to point to the dir. Still I got the
same exception.
Then I made the plugin mandatory and I got
"org.elasticsearch.ElasticSearchException: Missing mandatory plugins
[river-jdbc]

org.elasticsearch.plugins.PluginsService.<init>(PluginsService.java:99)
"

BTW, I gave the absolute path for the above.

Thanks and Regards

bin :slight_smile:

On Wednesday, September 11, 2013 6:47:48 PM UTC+5:30, David Pilato wrote:

You can also just add your plugin in the classloader.
For example, add it as a maven dependency in your project and that's all.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 11 sept. 2013 à 15:00, Igor Motov imo...@gmail.com a écrit :

Just copy the plugin to any directory that is accessible by the tomcat
process and specify this directory in the path.plugins setting of your
elasticsearch node.

On Wednesday, September 11, 2013 8:27:42 AM UTC-4, bin wrote:

Hi,

I have wrapped Elasticsearch in Tomcat and am using
elasticsearch-transport-wares for this purpose. How can I add a plugin to
this instance as Im planning to use jdbc river plugin?

Thanks & Regards

bin :slight_smile:

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #7

I did not play with wares plugin.
As you are using tomcat, you could try to add all needed libs (and their dependencies!) in:
WEB-INF/lib or
$CATALINA_HOME/lib
I would recommend to restart tomcat.

Did you add all dependencies? Is there anything in logs?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 12 sept. 2013 à 03:13, bin bibin.abraham.dev@gmail.com a écrit :

I am using elasticsearch-transport-wares servlets

Thanks & Regards

bin :slight_smile:

On Thursday, 12 September 2013 01:02:24 UTC+5:30, David Pilato wrote:
How do you start es from your webapp?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 11 sept. 2013 à 20:16, bin bibin.ab...@gmail.com a écrit :

Hi Igor,David,

Thanks for your help.

I added the river-jdbc jar in WEB-INF/lib. Then I tried the following:

curl -XPUT "http://localhost:9200/_river/my_jdbc_river/_meta" -d '{...}'

output:
{
"error": "IndexMissingException[[_river] missing]",
"status": 404
}

Then I created a folder-plugins/river-jdbc and added its jars over there. I configured the elasticsearch.yml to point to the dir. Still I got the same exception.
Then I made the plugin mandatory and I got
"org.elasticsearch.ElasticSearchException: Missing mandatory plugins [river-jdbc]
org.elasticsearch.plugins.PluginsService.<init>(PluginsService.java:99)
"

BTW, I gave the absolute path for the above.

Thanks and Regards

bin :slight_smile:

On Wednesday, September 11, 2013 6:47:48 PM UTC+5:30, David Pilato wrote:
You can also just add your plugin in the classloader.
For example, add it as a maven dependency in your project and that's all.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 11 sept. 2013 à 15:00, Igor Motov imo...@gmail.com a écrit :

Just copy the plugin to any directory that is accessible by the tomcat process and specify this directory in the path.plugins setting of your elasticsearch node.

On Wednesday, September 11, 2013 8:27:42 AM UTC-4, bin wrote:
Hi,

I have wrapped Elasticsearch in Tomcat and am using elasticsearch-transport-wares for this purpose. How can I add a plugin to this instance as Im planning to use jdbc river plugin?

Thanks & Regards

bin :slight_smile:

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #8