Incorrect "Time" field in Discover tab

I have a monthly time-based index pattern [engine-live-]YYY.MM, where the time field is _timestamp.

In the discover tab, I can see my documents properly "distributed" on the time histogram at the very top. However, in the text view below, all items share the exact same "Time" value that seems to roughly correspond to my query time.

If I expand one of those documents and look at the JSON, I can see the "fields": { "_timestamp": x } } value is correct and different from what is displayed in the "Time" column. The "sort" attribute also has the same (correct) value than the _timestamp field.

He is an example where you can see the JSON data and the "Time" column mismatch (I'm in PST, so 1446010774000 == 10:39:34PM):

How can I get the "Time" column to display the value of the _timestamp field? Is seems like a bug, but I failed to find anything related to this on GitHub.

My Kibana version is 4.1.2. My mapping defines that _timestamp is both "enabled": true and "store": true.

Interesting - Are the documents updated in any way after they are originally inserted into ES? I saw this bug that is supposed to be fixed in 4.2 that seems potentially related:

Thanks Tanya! I would have to double check, but unless there is a bug on my feeding process, those documents should never be updated after being initially indexed.