Increase LS_OPEN_FILES beyond 16384


#1

Hi guys,

Hope my question isn't too trivial but I can't seem to find any other setting to increase this value.

PID for logstash service is XXX and proc limits:
    cat /proc/XXX/limits
    Max open files            16384                16384                files

I added 50000 to:

/etc/security/limits.conf
logstash        hard    nofile          50000

/etc/logstash/startup.options
    # Open file limit
    LS_OPEN_FILES=50000

/etc/default/logstash
LS_OPEN_FILES="50000"

and to .conf file
max_open_files => 50000

I don't have a logstash file in /etc/init.d.

I rebooted the server and after starting logstash the limit is still 16384.

Can you help what I'm missing?
Server is running CentOS 7.

Thank you!


#2

Got it. Needed alto to change the value in:

/etc/systemd/system/logstash.service
LimitNOFILE=50000

And restart.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.