Increase max queue capacity?


(Wanderer) #1

Running 6.2.4 We are getting this error in one of our dashboards.

rejected execution of org.elasticsearch.common.util.concurrent.TimedRunnable@55490381 on QueueResizingEsThreadPoolExecutor[name = es-01/search, queue capacity = 1000, min queue capacity = 1000, max queue capacity = 1000, frame size = 2000, targeted response rate = 1s, task execution EWMA = 27.3ms, adjustment amount = 50, org.elasticsearch.common.util.concurrent.QueueResizingEsThreadPoolExecutor@450c7b3f[Running, pool size = 10, active threads = 10, queued tasks = 1392, completed tasks = 805972]]

What is the way to increase the queue capacity? We cannot add more nodes at the moment.


(Mark Walkom) #2

This will only increase the pressure on your cluster.

Why is it creating such a high use of the threadpools? Do you have Monitoring enabled?


(Wanderer) #3

We have one dashboard that causes this. The visualization on their own do work fine.

Monitoring enabled? What do you mean?


(Christian Dahlqvist) #4

How many visualisations does this dashboard have? How many shards does it address?


(Wanderer) #5

15 visualizations. Screenshot shows the current shards. Not sure why metricbeat is only showing 1. Most of the visualiztions with issues are metricbeat.


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.